summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/launchy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/launchy')
-rw-r--r--dev-ruby/launchy/Manifest1
-rw-r--r--dev-ruby/launchy/files/launchy-2.3.0-drop-failing-test.patch24
-rw-r--r--dev-ruby/launchy/files/launchy-2.4.2-drop-failing-test.patch25
-rw-r--r--dev-ruby/launchy/launchy-2.4.3.ebuild37
-rw-r--r--dev-ruby/launchy/metadata.xml5
5 files changed, 92 insertions, 0 deletions
diff --git a/dev-ruby/launchy/Manifest b/dev-ruby/launchy/Manifest
new file mode 100644
index 000000000000..247482c216c1
--- /dev/null
+++ b/dev-ruby/launchy/Manifest
@@ -0,0 +1 @@
+DIST launchy-2.4.3.gem 29184 SHA256 42f52ce12c6fe079bac8a804c66522a0eefe176b845a62df829defe0e37214a4 SHA512 7c3e0377c9a310b2e7a4d1544b4790f6f959d24b6aba91660e979eb943f4bee641e0b5a44687b693ffe99304ceb96a9a6cf9fed142e231af01135bd2b73321d6 WHIRLPOOL 3845161e674d2369a3a95e1b3127e4f186849c5130dd0c29dcf4fa2cf2760a46db88f8411652be3655fdf6649bec40b6f9034cdaff8ca73b6fc56c9366e648c2
diff --git a/dev-ruby/launchy/files/launchy-2.3.0-drop-failing-test.patch b/dev-ruby/launchy/files/launchy-2.3.0-drop-failing-test.patch
new file mode 100644
index 000000000000..3304a0ae090d
--- /dev/null
+++ b/dev-ruby/launchy/files/launchy-2.3.0-drop-failing-test.patch
@@ -0,0 +1,24 @@
+diff --git a/spec/applications/browser_spec.rb b/spec/applications/browser_spec.rb
+index 8cfa8e7..3886ce3 100644
+--- a/spec/applications/browser_spec.rb
++++ b/spec/applications/browser_spec.rb
+@@ -12,19 +12,6 @@ describe Launchy::Application::Browser do
+ ENV.delete( 'KDE_FULL_SESSION' )
+ end
+
+- { 'windows' => 'start /b' ,
+- 'darwin' => '/usr/bin/open',
+- 'cygwin' => 'cmd /C start /b',
+-
+- # when running these tests on a linux box, this test will fail
+- 'linux' => nil }.each do |host_os, cmdline|
+- it "when host_os is '#{host_os}' the appropriate 'app_list' method is called" do
+- Launchy.host_os = host_os
+- browser = Launchy::Application::Browser.new
+- browser.app_list.first.must_equal cmdline
+- end
+- end
+-
+ %w[ linux windows darwin cygwin ].each do |host_os|
+ it "the BROWSER environment variable overrides any host defaults on '#{host_os}'" do
+ ENV['BROWSER'] = "my_special_browser --new-tab '%s'"
diff --git a/dev-ruby/launchy/files/launchy-2.4.2-drop-failing-test.patch b/dev-ruby/launchy/files/launchy-2.4.2-drop-failing-test.patch
new file mode 100644
index 000000000000..00a0d4bf27e0
--- /dev/null
+++ b/dev-ruby/launchy/files/launchy-2.4.2-drop-failing-test.patch
@@ -0,0 +1,25 @@
+diff --git a/spec/applications/browser_spec.rb b/spec/applications/browser_spec.rb
+index 8cfa8e7..3886ce3 100644
+--- a/spec/applications/browser_spec.rb
++++ b/spec/applications/browser_spec.rb
+@@ -12,20 +12,7 @@ describe Launchy::Application::Browser do
+ ENV.delete( 'KDE_FULL_SESSION' )
+ ENV.delete( 'BROWSER' )
+ end
+
+- { 'windows' => 'start "launchy" /b' ,
+- 'darwin' => '/usr/bin/open',
+- 'cygwin' => 'cmd /C start "launchy" /b',
+-
+- # when running these tests on a linux box, this test will fail
+- 'linux' => nil }.each do |host_os, cmdline|
+- it "when host_os is '#{host_os}' the appropriate 'app_list' method is called" do
+- Launchy.host_os = host_os
+- browser = Launchy::Application::Browser.new
+- browser.app_list.first.must_equal cmdline
+- end
+- end
+-
+ %w[ linux windows darwin cygwin ].each do |host_os|
+ it "the BROWSER environment variable overrides any host defaults on '#{host_os}'" do
+ ENV['BROWSER'] = "my_special_browser --new-tab '%s'"
diff --git a/dev-ruby/launchy/launchy-2.4.3.ebuild b/dev-ruby/launchy/launchy-2.4.3.ebuild
new file mode 100644
index 000000000000..1e790e4891b4
--- /dev/null
+++ b/dev-ruby/launchy/launchy-2.4.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="README.md HISTORY.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Helper class for launching cross-platform applications"
+HOMEPAGE="http://copiousfreetime.rubyforge.org/launchy/"
+
+LICENSE="ISC"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# File collision conflict with x11-misc/launchy, bug 545170
+ruby_add_rdepend ">=dev-ruby/addressable-2.3 !!x11-misc/launchy"
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.0:5 )"
+
+# This test is expected to fail on linux, drop it
+RUBY_PATCHES=( "${FILESDIR}"/${PN}-2.4.2-drop-failing-test.patch )
+
+all_ruby_prepare() {
+ sed -i -e "/[Ss]implecov/d" spec/spec_helper.rb || die
+
+ # Avoid tests depending on the current user's desktop environment.
+ sed -e '/returns NotFound if it cannot determine/askip "gentoo"' \
+ -i spec/detect/nix_desktop_environment_spec.rb || die
+ sed -e '/asssumes we open a local file if we have an exception/askip "gentoo"' \
+ -i spec/launchy_spec.rb || die
+}
diff --git a/dev-ruby/launchy/metadata.xml b/dev-ruby/launchy/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/launchy/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>