summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/matchy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/matchy')
-rw-r--r--dev-ruby/matchy/Manifest1
-rw-r--r--dev-ruby/matchy/matchy-0.5.2-r1.ebuild33
-rw-r--r--dev-ruby/matchy/metadata.xml8
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/matchy/Manifest b/dev-ruby/matchy/Manifest
new file mode 100644
index 000000000000..bf708e8c6270
--- /dev/null
+++ b/dev-ruby/matchy/Manifest
@@ -0,0 +1 @@
+DIST mcmire-matchy-0.5.2.gem 16384 SHA256 9d43d0e31c6230202d08135006d6ad65bd403bf19c34dd108e471d01ed3a04ec SHA512 24b19ad93b2a38439a82326a9acd67e13855d224a4c5730adf9271c1d1329ecfad0bcda5d19a4aa1f3c0f9667946ce624c9a1db30a45e77a3ad0acdb535c39d1 WHIRLPOOL 2729b2c153163f84383ced4cbd9152c6b5131755d6f461ff5c155333a5095268c46239900152c1ea8f2c6920fdf824405eeb555ca868775fb0728ab4e2ffe754
diff --git a/dev-ruby/matchy/matchy-0.5.2-r1.ebuild b/dev-ruby/matchy/matchy-0.5.2-r1.ebuild
new file mode 100644
index 000000000000..f809e7f8ad51
--- /dev/null
+++ b/dev-ruby/matchy/matchy-0.5.2-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_OWNER="mcmire"
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+RUBY_FAKEGEM_NAME="${MY_OWNER}-${PN}"
+
+inherit ruby-fakegem
+
+DESCRIPTION="RSpec-esque matchers for use in Test::Unit"
+HOMEPAGE="http://github.com/mcmire/matchy"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e 's:rake/rdoctask:rdoc/task:' Rakefile || die
+}
+
+# workaround for ruby 1.9.2, sent upstream after 0.5.2
+each_ruby_test() {
+ RUBYLIB="$(pwd)${RUBYLIB+:${RUBYLIB}}" each_fakegem_test
+}
diff --git a/dev-ruby/matchy/metadata.xml b/dev-ruby/matchy/metadata.xml
new file mode 100644
index 000000000000..bcd12b0fcd21
--- /dev/null
+++ b/dev-ruby/matchy/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">mcmire/matchy</remote-id>
+ </upstream>
+</pkgmetadata>