summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2015-09-04 17:02:30 -0400
committerZero_Chaos <zerochaos@gentoo.org>2015-09-04 17:02:50 -0400
commit02bd428e62ca2cba9e41b923386b564283caa763 (patch)
tree32b4db545f0dc73d144a950f2a1383ec01375faf /dev-ruby/metasploit-credential
parentnet-misc/dhcpcd: version bump (diff)
downloadgentoo-02bd428e62ca2cba9e41b923386b564283caa763.tar.gz
gentoo-02bd428e62ca2cba9e41b923386b564283caa763.tar.bz2
gentoo-02bd428e62ca2cba9e41b923386b564283caa763.zip
net-analyzer/metasploit: add a modern version of metasploit (and a ton of deps for it)
Diffstat (limited to 'dev-ruby/metasploit-credential')
-rw-r--r--dev-ruby/metasploit-credential/Manifest1
-rw-r--r--dev-ruby/metasploit-credential/metadata.xml13
-rw-r--r--dev-ruby/metasploit-credential/metasploit-credential-1.0.0.ebuild52
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-ruby/metasploit-credential/Manifest b/dev-ruby/metasploit-credential/Manifest
new file mode 100644
index 000000000000..948e652c654d
--- /dev/null
+++ b/dev-ruby/metasploit-credential/Manifest
@@ -0,0 +1 @@
+DIST metasploit-credential-1.0.0.gem 101888 SHA256 086cb65295f1294c213138bd2a9f2f727d945b90837a7e877b22bc6a47fe33f6 SHA512 4af09458a83d9425c5bfd744bc3f366c08d9175b4c303fa9ff53dd3f2163ba654748ea883d22f069e3b3be1218b57afe909f7ba31feb54c0b7ff781af8d5e631 WHIRLPOOL 506c707f3e1be0e90fad02397a34c70e44d1f423b5909d9f61152e2a4e929eadccf0736ec607c569fe75fff24c6003243d0a9a288979450b8c52d5f1feba1f6d
diff --git a/dev-ruby/metasploit-credential/metadata.xml b/dev-ruby/metasploit-credential/metadata.xml
new file mode 100644
index 000000000000..7b6d0792a58d
--- /dev/null
+++ b/dev-ruby/metasploit-credential/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+<longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="github">rapid7/metasploit-credential</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/metasploit-credential/metasploit-credential-1.0.0.ebuild b/dev-ruby/metasploit-credential/metasploit-credential-1.0.0.ebuild
new file mode 100644
index 000000000000..98db6b6be7ef
--- /dev/null
+++ b/dev-ruby/metasploit-credential/metasploit-credential-1.0.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+inherit ruby-fakegem versionator
+
+RUBY_FAKEGEM_EXTRAINSTALL="app config db spec"
+
+DESCRIPTION="Code for modeling and managing credentials in Metasploit"
+HOMEPAGE="https://github.com/rapid7/metasploit-credential"
+SRC_URI="mirror://rubygems/${P}.gem"
+
+LICENSE="BSD"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/metasploit-concern-1.0.0:1.0
+ >=dev-ruby/metasploit_data_models-1.2.0
+ >=dev-ruby/metasploit-model-1.0.0
+ dev-ruby/rubyzip:1
+ dev-ruby/rubyntlm
+ >=dev-ruby/railties-4.0.9:4.0
+ dev-ruby/net-ssh
+ dev-ruby/pg"
+ruby_add_bdepend "dev-ruby/bundler"
+
+all_ruby_prepare() {
+ [ -f Gemfile.lock ] && rm Gemfile.lock
+ #For now, we don't support development or testing at all
+ #if ! use development; then
+ sed -i -e "/^group :development do/,/^end$/d" Gemfile || die
+ sed -i -e "/s.add_development_dependency/d" "${PN}".gemspec || die
+ #fi
+ #if ! use test; then
+ sed -i -e "/^group :test do/,/^end$/d" Gemfile || die
+ #fi
+ #if ! use test && ! use development; then
+ sed -i -e "/^group :development, :test do/,/^end$/d" Gemfile || die
+ #fi
+}
+
+each_ruby_prepare() {
+ if [ -f Gemfile ]
+ then
+ BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle install --local || die
+ BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle check || die
+ fi
+}