summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2016-01-26 14:41:38 -0500
committerZero_Chaos <zerochaos@gentoo.org>2016-01-26 14:42:03 -0500
commitabe2f5c24cd79e97dc9c483843b099ab4a958965 (patch)
tree9d77560506245532178e81302a329a6cd6681247 /dev-ruby/metasploit_data_models/metasploit_data_models-1.2.10.ebuild
parentdev-ruby/metasploit-payloads: drop ruby19 and fix copyright year (diff)
downloadgentoo-abe2f5c24cd79e97dc9c483843b099ab4a958965.tar.gz
gentoo-abe2f5c24cd79e97dc9c483843b099ab4a958965.tar.bz2
gentoo-abe2f5c24cd79e97dc9c483843b099ab4a958965.zip
dev-ruby/metasploit_data_models: bump, remove ruby19
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-ruby/metasploit_data_models/metasploit_data_models-1.2.10.ebuild')
-rw-r--r--dev-ruby/metasploit_data_models/metasploit_data_models-1.2.10.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-ruby/metasploit_data_models/metasploit_data_models-1.2.10.ebuild b/dev-ruby/metasploit_data_models/metasploit_data_models-1.2.10.ebuild
new file mode 100644
index 000000000000..6a0cb28c67a4
--- /dev/null
+++ b/dev-ruby/metasploit_data_models/metasploit_data_models-1.2.10.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21"
+
+inherit ruby-fakegem
+
+RUBY_FAKEGEM_EXTRAINSTALL="app config db script spec"
+
+DESCRIPTION="The database layer for Metasploit"
+HOMEPAGE="https://github.com/rapid7/metasploit_data_models"
+SRC_URI="mirror://rubygems/${P}.gem"
+
+LICENSE="BSD"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+RESTRICT=test
+#IUSE="development test"
+IUSE=""
+
+RDEPEND="${RDEPEND} !dev-ruby/metasploit_data_models:0"
+
+ruby_add_rdepend "
+ >=dev-ruby/activerecord-4.0.9:4.0[postgres]
+ >=dev-ruby/activesupport-4.0.9:4.0
+ dev-ruby/pg
+ dev-ruby/postgres_ext
+ >=dev-ruby/railties-4.0.9:4.0
+ dev-ruby/recog:*
+ dev-ruby/arel-helpers
+ >=dev-ruby/metasploit-concern-1.0.0:1.0
+ >=dev-ruby/metasploit-model-1.0.0:1.0
+ <dev-ruby/thor-2.0"
+
+ruby_add_bdepend "dev-ruby/bundler"
+
+all_ruby_prepare() {
+ [ -f Gemfile.lock ] && rm Gemfile.lock
+ #if ! use development; then
+ sed -i -e "/^group :development do/,/^end$/d" Gemfile || die
+ sed -i -e "/s.add_development_dependency/d" "${PN}".gemspec || die
+ #fi
+ #if ! use test; then
+ sed -i -e "/^group :test do/,/^end$/d" Gemfile || die
+ #fi
+ #if ! use test && ! use development; then
+ sed -i -e "/^group :development, :test do/,/^end$/d" Gemfile || die
+ #fi
+}
+
+each_ruby_prepare() {
+ if [ -f Gemfile ]
+ then
+ BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle install --local || die
+ BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle check || die
+ fi
+}
+
+all_ruby_install() {
+ ruby_fakegem_binwrapper mdm_console mdm_console-${SLOT}
+}