summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-01-16 08:03:11 +0100
committerHans de Graaff <graaff@gentoo.org>2019-01-16 08:24:32 +0100
commitc4ab46dfb6fd36b42fe1a0705fbfb7a00e5c08c1 (patch)
tree17fd843f80a31f4f3fd174a8201eff24b9fe22c2 /dev-ruby/mocha/mocha-1.8.0.ebuild
parentdev-ruby/launchy: add ruby26 (diff)
downloadgentoo-c4ab46dfb6fd36b42fe1a0705fbfb7a00e5c08c1.tar.gz
gentoo-c4ab46dfb6fd36b42fe1a0705fbfb7a00e5c08c1.tar.bz2
gentoo-c4ab46dfb6fd36b42fe1a0705fbfb7a00e5c08c1.zip
dev-ruby/mocha: add 1.8.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/mocha/mocha-1.8.0.ebuild')
-rw-r--r--dev-ruby/mocha/mocha-1.8.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/mocha/mocha-1.8.0.ebuild b/dev-ruby/mocha/mocha-1.8.0.ebuild
new file mode 100644
index 000000000000..6a986edc6390
--- /dev/null
+++ b/dev-ruby/mocha/mocha-1.8.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_TEST="test:units test:acceptance"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md RELEASE.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Mocking and stubbing using a syntax like that of JMock and SchMock"
+HOMEPAGE="https://mocha.jamesmead.org/"
+
+LICENSE="MIT"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+ruby_add_bdepend "
+ test? ( >=dev-ruby/test-unit-2.5.1-r1 dev-ruby/introspection )"
+
+ruby_add_rdepend "=dev-ruby/metaclass-0.0*"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' -e '1iload "lib/mocha/version.rb"' Rakefile || die
+}
+
+each_ruby_test() {
+ export MOCHA_NO_DOCS=true
+ each_fakegem_test
+}