summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-05-13 19:19:21 +0200
committerHans de Graaff <graaff@gentoo.org>2019-05-13 19:19:21 +0200
commit45fae522432df1a969339cdbf62f03f80a289a14 (patch)
tree05f9ba602cb71992ba90b1f1979b61cf379c2618 /dev-ruby/multi_json
parentdev-ruby/nokogiri: s390 stable wrt bug #682052 (diff)
downloadgentoo-45fae522432df1a969339cdbf62f03f80a289a14.tar.gz
gentoo-45fae522432df1a969339cdbf62f03f80a289a14.tar.bz2
gentoo-45fae522432df1a969339cdbf62f03f80a289a14.zip
dev-ruby/multi_json: cleanup
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/multi_json')
-rw-r--r--dev-ruby/multi_json/Manifest1
-rw-r--r--dev-ruby/multi_json/multi_json-1.12.1.ebuild61
2 files changed, 0 insertions, 62 deletions
diff --git a/dev-ruby/multi_json/Manifest b/dev-ruby/multi_json/Manifest
index a830cdee0714..d3350d818abc 100644
--- a/dev-ruby/multi_json/Manifest
+++ b/dev-ruby/multi_json/Manifest
@@ -1,2 +1 @@
-DIST multi_json-1.12.1.tar.gz 25579 BLAKE2B 50fa37b907289b8247ffff1e22ebde1b07ee32e5ca97984be1243340f14185ebaaeb72cb28a18c5c77b1b48bfd0b400479fe7ef532e40cef3736d782c84c0d09 SHA512 f61e500197c5a1373443b308bd9307238c54d2d23ba9da91843c667c12e491f34fd87575028c3630a81a7355d4903344996f20408bbb7971b12dfba3cc4f76df
DIST multi_json-1.13.1.tar.gz 26098 BLAKE2B e82a08a747a092a9094cd7b35b4f933b5ac922a01f45a51b215ca9c4cdb9a083a4808d4bbe67a147ecb57e0b7b7e313c3d896f8cd80c79338c24abc3b90a09f9 SHA512 7c98392bd1c909fcc05249a02a010b561bf6c2d812ae42413d6e8dafa62926d8cb76226ded4c61558a00e5fa531ba33b6f4ef562648c52ba9b552ff7b7e27682
diff --git a/dev-ruby/multi_json/multi_json-1.12.1.ebuild b/dev-ruby/multi_json/multi_json-1.12.1.ebuild
deleted file mode 100644
index 7f357ab7ec0b..000000000000
--- a/dev-ruby/multi_json/multi_json-1.12.1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby21 ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_TASK_DOC="yard"
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="multi_json.gemspec"
-
-inherit ruby-fakegem
-
-SRC_URI="https://github.com/intridea/multi_json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-DESCRIPTION="A gem to provide swappable JSON backends"
-HOMEPAGE="https://github.com/intridea/multi_json"
-LICENSE="MIT"
-
-KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ppc ppc64 s390 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-ruby_add_rdepend "|| ( >=dev-ruby/json-1.4 >=dev-ruby/yajl-ruby-1.0 )"
-
-ruby_add_bdepend "doc? ( dev-ruby/rspec:3 dev-ruby/yard )"
-
-ruby_add_bdepend "test? ( dev-ruby/json
- dev-ruby/yajl-ruby )"
-
-all_ruby_prepare() {
- sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb || die "Unable to remove bundler."
-
- # Remove unimportant rspec options not supported by rspec 2.6.
- rm .rspec || die
-
- # Remove specs specific to oj since we don't package oj yet.
- sed -i -e '/defaults to the best available gem/,/^ end/ s:^:#:' \
- -e '/Oj does not create symbols on parse/,/^ end/ s:^:#:' \
- -e '/with Oj.default_settings/,/^ end/ s:^:#:' \
- -e '/using one-shot parser/,/^ end/ s:^:#:' \
- spec/multi_json_spec.rb
-
- # Avoid simplecov which only works with ruby 1.9
- sed -i -e '/simplecov/d' -e '/SimpleCov.formatter/,/SimpleCov.start/ d' spec/spec_helper.rb || die
-
- # Remove unpackaged and for our purposes unneeded coveralls
- sed -i -e '/coveralls/d' spec/spec_helper.rb || die
-
- # Avoid testing unpackaged adapters
- rm spec/{gson,jr_jackson,oj}_adapter_spec.rb || die
-}
-
-each_ruby_test() {
- for t in spec/*_spec.rb; do
- ${RUBY} -S rspec-3 ${t} || die
- done
-}