summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/mysql2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/mysql2')
-rw-r--r--dev-ruby/mysql2/Manifest3
-rw-r--r--dev-ruby/mysql2/metadata.xml8
-rw-r--r--dev-ruby/mysql2/mysql2-0.3.17.ebuild35
-rw-r--r--dev-ruby/mysql2/mysql2-0.3.18.ebuild35
-rw-r--r--dev-ruby/mysql2/mysql2-0.3.19.ebuild35
5 files changed, 116 insertions, 0 deletions
diff --git a/dev-ruby/mysql2/Manifest b/dev-ruby/mysql2/Manifest
new file mode 100644
index 000000000000..daa1c8f1f5d8
--- /dev/null
+++ b/dev-ruby/mysql2/Manifest
@@ -0,0 +1,3 @@
+DIST mysql2-0.3.17.gem 49152 SHA256 c69c5f08532cdd58e5f7dccaad7ac132edaa271dd2c8d69711cf5ce3c8f858e1 SHA512 bf3e818fa6a2396706b5078ab6a426ce22e7a24ca8e0ba310e831ed1887f9d6688084d99af34111f6447f089a2bf1364dd641434b61add9778eed5c4ce2d270e WHIRLPOOL 904e5def78e6a5457b7dfc7a561d7ddb9900f57812bc68b4b52dec3095276b93626198af4b29d648655143e93b210dfd66fa0dba202d16e1ef8d4e03ed93c016
+DIST mysql2-0.3.18.gem 50688 SHA256 d35477aaf1a5fc508511af5c521675b8878275ad0af9c12e1cf222b50e285735 SHA512 533cbea6c67ce1d02861d76b18c3a3c74e81a6f4edf0324dfeb29dc9f8a4fb40e5a4e4bc22b973784c1a6ac1862507860b50d5ce7da4aeac6e3a3c260f1fde7d WHIRLPOOL a6685345d5a82c098cbc40d5963d5be3cc0f16738d197cc40ec2a7b375ca578078f177dccfadd8aaee2a8eb85e346f9f097b0bc7af01045ccec3cc44f6226252
+DIST mysql2-0.3.19.gem 52224 SHA256 d34c6804e1916361ff352da0f0f57e615909cad0edcbf18d9aba78e1ddc2918a SHA512 1486e6016854776307a42b8edd1b51f222c9ec4a3aa769aba03579c132e778673ed5cd788d129fecb73085a01989adf9813d36d20ff292573b6db041354270f5 WHIRLPOOL 12db1a0c0b8260bae189590094978038903e871e1e91cf9d502117a05807344a60d9b40be0c8a45e5be74f027eefbf7e2c2ab5d5ba2d8e9bcdabaf6b41c8024b
diff --git a/dev-ruby/mysql2/metadata.xml b/dev-ruby/mysql2/metadata.xml
new file mode 100644
index 000000000000..7bff423b39a2
--- /dev/null
+++ b/dev-ruby/mysql2/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">brianmario/mysql2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/mysql2/mysql2-0.3.17.ebuild b/dev-ruby/mysql2/mysql2-0.3.17.ebuild
new file mode 100644
index 000000000000..5cb7f3b05d0c
--- /dev/null
+++ b/dev-ruby/mysql2/mysql2-0.3.17.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+# Tests require a live MySQL database but should all pass.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A modern, simple and very fast Mysql library for Ruby - binding to libmysql"
+HOMEPAGE="https://github.com/brianmario/mysql2"
+
+LICENSE="MIT"
+SLOT="0.3"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="${DEPEND} virtual/mysql[-static]"
+RDEPEND="${RDEPEND} virtual/mysql[-static]"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/mysql2 extconf.rb --with-mysql-config "${EPREFIX}/usr/bin/mysqlconfig" || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/mysql2 || die
+ cp ext/mysql2/mysql2$(get_modname) lib/mysql2/ || die
+}
diff --git a/dev-ruby/mysql2/mysql2-0.3.18.ebuild b/dev-ruby/mysql2/mysql2-0.3.18.ebuild
new file mode 100644
index 000000000000..dfc9ed5468dc
--- /dev/null
+++ b/dev-ruby/mysql2/mysql2-0.3.18.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+# Tests require a live MySQL database but should all pass.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A modern, simple and very fast Mysql library for Ruby - binding to libmysql"
+HOMEPAGE="https://github.com/brianmario/mysql2"
+
+LICENSE="MIT"
+SLOT="0.3"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="${DEPEND} virtual/mysql[-static]"
+RDEPEND="${RDEPEND} virtual/mysql:=[-static]"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/mysql2 extconf.rb --with-mysql-config "${EPREFIX}/usr/bin/mysqlconfig" || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/mysql2 || die
+ cp ext/mysql2/mysql2$(get_modname) lib/mysql2/ || die
+}
diff --git a/dev-ruby/mysql2/mysql2-0.3.19.ebuild b/dev-ruby/mysql2/mysql2-0.3.19.ebuild
new file mode 100644
index 000000000000..ef3a37f29621
--- /dev/null
+++ b/dev-ruby/mysql2/mysql2-0.3.19.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+# Tests require a live MySQL database but should all pass.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A modern, simple and very fast Mysql library for Ruby - binding to libmysql"
+HOMEPAGE="https://github.com/brianmario/mysql2"
+
+LICENSE="MIT"
+SLOT="0.3"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="${DEPEND} virtual/libmysqlclient"
+RDEPEND="${RDEPEND} virtual/libmysqlclient:="
+
+each_ruby_configure() {
+ ${RUBY} -Cext/mysql2 extconf.rb --with-mysql-config "${EPREFIX}/usr/bin/mysqlconfig" || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/mysql2 || die
+ cp ext/mysql2/mysql2$(get_modname) lib/mysql2/ || die
+}