summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/network_interface
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/network_interface')
-rw-r--r--dev-ruby/network_interface/Manifest1
-rw-r--r--dev-ruby/network_interface/metadata.xml13
-rw-r--r--dev-ruby/network_interface/network_interface-0.0.1-r1.ebuild37
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-ruby/network_interface/Manifest b/dev-ruby/network_interface/Manifest
new file mode 100644
index 000000000000..6a18a3cf4bd0
--- /dev/null
+++ b/dev-ruby/network_interface/Manifest
@@ -0,0 +1 @@
+DIST network_interface-0.0.1.gem 15360 SHA256 eaa48bd219fdcb9b6c66d44f1aa2b4e1c51385114400187d7fc087bf76602447 SHA512 db41bcb5669ddec954d5910b0c53a5dab81d4283d8e45eb88cdc855084ddcc7219b506745f6dacd172b5c17479f28a68b68f40e1928d573cdf22c567805e498c WHIRLPOOL 9dfec4aaf9629e0d21da507744c6462e05fbca21055d31982722d889ed7134adc2c5e10cdc76e9a0adaa493ad081f329c31afd08f7a9c62c071f9b908c3881e9
diff --git a/dev-ruby/network_interface/metadata.xml b/dev-ruby/network_interface/metadata.xml
new file mode 100644
index 000000000000..ec0d6fcb3865
--- /dev/null
+++ b/dev-ruby/network_interface/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="github">rapid7/network_interface</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/network_interface/network_interface-0.0.1-r1.ebuild b/dev-ruby/network_interface/network_interface-0.0.1-r1.ebuild
new file mode 100644
index 000000000000..592553d19ee6
--- /dev/null
+++ b/dev-ruby/network_interface/network_interface-0.0.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="network_interface layer from metasploit pcaprub"
+HOMEPAGE="https://github.com/rapid7/network_interface"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+# Tests are brittle as they cannot deal with all network interface configurations.
+RESTRICT="test"
+
+all_ruby_prepare() {
+ sed -i -e 's:/sbin/ifconfig:/bin/ifconfig:' spec/spec_helper.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext/network_interface_ext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -C ext/network_interface_ext V=1
+ cp ext/network_interface_ext/network_interface_ext.so lib/ || die
+}