summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-12-04 06:38:26 +0100
committerHans de Graaff <graaff@gentoo.org>2018-12-04 06:38:26 +0100
commit59e88c19ccbcacb2c79fb80a6465ae244b22e096 (patch)
tree37eb259594c9333d2b90d9f448764682fe0422d8 /dev-ruby/oauth2
parentdev-ruby/magic: cleanup (diff)
downloadgentoo-59e88c19ccbcacb2c79fb80a6465ae244b22e096.tar.gz
gentoo-59e88c19ccbcacb2c79fb80a6465ae244b22e096.tar.bz2
gentoo-59e88c19ccbcacb2c79fb80a6465ae244b22e096.zip
dev-ruby/oauth2: cleanup
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/oauth2')
-rw-r--r--dev-ruby/oauth2/oauth2-1.4.0-r1.ebuild46
-rw-r--r--dev-ruby/oauth2/oauth2-1.4.0.ebuild42
2 files changed, 0 insertions, 88 deletions
diff --git a/dev-ruby/oauth2/oauth2-1.4.0-r1.ebuild b/dev-ruby/oauth2/oauth2-1.4.0-r1.ebuild
deleted file mode 100644
index d79d21c90151..000000000000
--- a/dev-ruby/oauth2/oauth2-1.4.0-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24"
-
-RUBY_FAKEGEM_TASK_TEST="none"
-RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="oauth2.gemspec"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="Wrapper for the OAuth 2.0 protocol with a similar style to the OAuth gem"
-HOMEPAGE="https://github.com/intridea/oauth2"
-SRC_URI="https://github.com/intridea/oauth2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/faraday-0.8 <dev-ruby/faraday-0.15
- >=dev-ruby/jwt-1.0 =dev-ruby/jwt-1*
- >=dev-ruby/multi_json-1.3 =dev-ruby/multi_json-1*
- >=dev-ruby/multi_xml-0.5:0
- >=dev-ruby/rack-1.2:* <dev-ruby/rack-3:*"
-ruby_add_bdepend "test? ( dev-ruby/rspec:3 )"
-
-all_ruby_prepare() {
- sed -i -e '/faraday/ s/0.13/0.15/' ${RUBY_FAKEGEM_GEMSPEC} || die
-
- sed -i -e '/simplecov/,/^ end/ s:^:#:' \
- -e '1irequire "uri"' spec/helper.rb || die
-
- sed -i -e '/yardstick/,/^end/ s:^:#:' \
- -e '/bundler/I s:^:#:' Rakefile || die
-}
-
-each_ruby_test() {
- CI=true ${RUBY} -S rspec-3 spec || die
-}
diff --git a/dev-ruby/oauth2/oauth2-1.4.0.ebuild b/dev-ruby/oauth2/oauth2-1.4.0.ebuild
deleted file mode 100644
index 9e36d65fce45..000000000000
--- a/dev-ruby/oauth2/oauth2-1.4.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_TASK_TEST="none"
-RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="Wrapper for the OAuth 2.0 protocol with a similar style to the OAuth gem"
-HOMEPAGE="https://github.com/intridea/oauth2"
-SRC_URI="https://github.com/intridea/oauth2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/faraday-0.8 <dev-ruby/faraday-0.13
- >=dev-ruby/jwt-1.0 =dev-ruby/jwt-1*
- >=dev-ruby/multi_json-1.3 =dev-ruby/multi_json-1*
- >=dev-ruby/multi_xml-0.5:0
- >=dev-ruby/rack-1.2:* <dev-ruby/rack-3:*"
-ruby_add_bdepend "test? ( dev-ruby/rspec:3 )"
-
-all_ruby_prepare() {
- sed -i -e '/simplecov/,/^ end/ s:^:#:' \
- -e '1irequire "uri"' spec/helper.rb || die
-
- sed -i -e '/yardstick/,/^end/ s:^:#:' \
- -e '/bundler/I s:^:#:' Rakefile || die
-}
-
-each_ruby_test() {
- CI=true ${RUBY} -S rspec-3 spec || die
-}