summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-11-09 00:44:28 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-11-09 00:44:28 +0100
commitef72ad1b78a0da15c5632ba6b5732ea14138f351 (patch)
tree523e751958e9ebdab7729dfd44d6ab86fd47c386 /dev-ruby/oauth2
parentdev-ruby/mixlib-shellout: Remove old (diff)
downloadgentoo-ef72ad1b78a0da15c5632ba6b5732ea14138f351.tar.gz
gentoo-ef72ad1b78a0da15c5632ba6b5732ea14138f351.tar.bz2
gentoo-ef72ad1b78a0da15c5632ba6b5732ea14138f351.zip
dev-ruby/oauth2: Add ruby23, drop ppc, x86, fix tarball
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-ruby/oauth2')
-rw-r--r--dev-ruby/oauth2/Manifest4
-rw-r--r--dev-ruby/oauth2/oauth2-1.1.0.ebuild2
-rw-r--r--dev-ruby/oauth2/oauth2-1.2.0-r1.ebuild42
-rw-r--r--dev-ruby/oauth2/oauth2-1.2.0.ebuild2
4 files changed, 46 insertions, 4 deletions
diff --git a/dev-ruby/oauth2/Manifest b/dev-ruby/oauth2/Manifest
index 284912852dd8..179d294022a3 100644
--- a/dev-ruby/oauth2/Manifest
+++ b/dev-ruby/oauth2/Manifest
@@ -1,2 +1,2 @@
-DIST v1.1.0.tar.gz 18376 SHA256 ea76a41dc7c559f9530e19961b5a8cd9a4b3f231f54901b9e6ef09031ce3aa77 SHA512 c4231093929733a662ed6246338508396eb0e8d1be48bff05c43a8e3f6dd38261667cad7db0dc44c3f6fd9152165b13fa46a779a05b3c1ae98f912f337820d2e WHIRLPOOL 0f9269df95ceabbcff65751d89bac5eef6bb18f34114b3045ac658325e7b8145f23fad311473c77e64f3170c45ccc880eb48c05ad6f174c7a42591995498a557
-DIST v1.2.0.tar.gz 18949 SHA256 e40fb1edaac68cb83bdbd1d6e2a1c485535278124c48f7b2db4771bb03c927d0 SHA512 2adacdc02752289eba217c6b2dfce0d00325becdbb7983b9fdfb149717ffd58cd235217048e48dc5be3d3c4024c224f8164cb0f9b4d792060554fbcb72e70536 WHIRLPOOL 138076cf3509b08ba40041be126d158ebd1767f043c0838789d28b5bce63b6c5ee49c2acfcf9ce81b9cc0303f618035366e947bc4bbd6e242658e973438cf5fc
+DIST oauth2-1.1.0.tar.gz 18376 SHA256 ea76a41dc7c559f9530e19961b5a8cd9a4b3f231f54901b9e6ef09031ce3aa77 SHA512 c4231093929733a662ed6246338508396eb0e8d1be48bff05c43a8e3f6dd38261667cad7db0dc44c3f6fd9152165b13fa46a779a05b3c1ae98f912f337820d2e WHIRLPOOL 0f9269df95ceabbcff65751d89bac5eef6bb18f34114b3045ac658325e7b8145f23fad311473c77e64f3170c45ccc880eb48c05ad6f174c7a42591995498a557
+DIST oauth2-1.2.0.tar.gz 18949 SHA256 e40fb1edaac68cb83bdbd1d6e2a1c485535278124c48f7b2db4771bb03c927d0 SHA512 2adacdc02752289eba217c6b2dfce0d00325becdbb7983b9fdfb149717ffd58cd235217048e48dc5be3d3c4024c224f8164cb0f9b4d792060554fbcb72e70536 WHIRLPOOL 138076cf3509b08ba40041be126d158ebd1767f043c0838789d28b5bce63b6c5ee49c2acfcf9ce81b9cc0303f618035366e947bc4bbd6e242658e973438cf5fc
diff --git a/dev-ruby/oauth2/oauth2-1.1.0.ebuild b/dev-ruby/oauth2/oauth2-1.1.0.ebuild
index de1e4a7a7099..ba5c08096fa9 100644
--- a/dev-ruby/oauth2/oauth2-1.1.0.ebuild
+++ b/dev-ruby/oauth2/oauth2-1.1.0.ebuild
@@ -16,7 +16,7 @@ inherit ruby-fakegem eutils
DESCRIPTION="Wrapper for the OAuth 2.0 protocol with a similar style to the OAuth gem"
HOMEPAGE="https://github.com/intridea/oauth2"
-SRC_URI="https://github.com/intridea/oauth2/archive/v${PV}.tar.gz"
+SRC_URI="https://github.com/intridea/oauth2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
diff --git a/dev-ruby/oauth2/oauth2-1.2.0-r1.ebuild b/dev-ruby/oauth2/oauth2-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..ff3d289bdd3d
--- /dev/null
+++ b/dev-ruby/oauth2/oauth2-1.2.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Wrapper for the OAuth 2.0 protocol with a similar style to the OAuth gem"
+HOMEPAGE="https://github.com/intridea/oauth2"
+SRC_URI="https://github.com/intridea/oauth2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/faraday-0.8
+ >=dev-ruby/jwt-1.0 =dev-ruby/jwt-1*
+ >=dev-ruby/multi_json-1.3 =dev-ruby/multi_json-1*
+ >=dev-ruby/multi_xml-0.5:0
+ >=dev-ruby/rack-1.2:* <dev-ruby/rack-3:*"
+ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.5.0:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/^ end/ s:^:#:' spec/helper.rb || die
+
+ sed -i -e '/yardstick/,/^end/ s:^:#:' \
+ -e '/bundler/I s:^:#:' Rakefile || die
+}
+
+each_ruby_test() {
+ CI=true ${RUBY} -S rspec spec || die
+}
diff --git a/dev-ruby/oauth2/oauth2-1.2.0.ebuild b/dev-ruby/oauth2/oauth2-1.2.0.ebuild
index fb15688a8ba1..cca55e5a2162 100644
--- a/dev-ruby/oauth2/oauth2-1.2.0.ebuild
+++ b/dev-ruby/oauth2/oauth2-1.2.0.ebuild
@@ -16,7 +16,7 @@ inherit ruby-fakegem eutils
DESCRIPTION="Wrapper for the OAuth 2.0 protocol with a similar style to the OAuth gem"
HOMEPAGE="https://github.com/intridea/oauth2"
-SRC_URI="https://github.com/intridea/oauth2/archive/v${PV}.tar.gz"
+SRC_URI="https://github.com/intridea/oauth2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"