summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-12-24 07:05:58 +0100
committerHans de Graaff <graaff@gentoo.org>2015-12-24 07:05:58 +0100
commite54f716d2bbb68a0c630b1487ad1f13989f6cc82 (patch)
treec060d101c93c553e964e2698235a3e599a825e41 /dev-ruby/omniauth/omniauth-1.3.1.ebuild
parentdev-ruby/nio4r: add 1.2.0 (diff)
downloadgentoo-e54f716d2bbb68a0c630b1487ad1f13989f6cc82.tar.gz
gentoo-e54f716d2bbb68a0c630b1487ad1f13989f6cc82.tar.bz2
gentoo-e54f716d2bbb68a0c630b1487ad1f13989f6cc82.zip
dev-ruby/omniauth: add 1.3.1
Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-ruby/omniauth/omniauth-1.3.1.ebuild')
-rw-r--r--dev-ruby/omniauth/omniauth-1.3.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/omniauth/omniauth-1.3.1.ebuild b/dev-ruby/omniauth/omniauth-1.3.1.ebuild
new file mode 100644
index 000000000000..86f9ee6fd165
--- /dev/null
+++ b/dev-ruby/omniauth/omniauth-1.3.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A generalized Rack framework for multiple-provider authentication"
+HOMEPAGE="https://github.com/intridea/omniauth"
+SRC_URI="https://github.com/intridea/omniauth/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rack:*
+ >=dev-ruby/hashie-1.2:* <dev-ruby/hashie-4:*"
+ruby_add_bdepend "doc? ( dev-ruby/yard )
+ test? ( dev-ruby/rack-test )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' \
+ Rakefile ${PN}.gemspec || die "sed failed"
+ sed -i -e '/RUBY_VERSION/,/^end/ s:^:#:' spec/helper.rb || die "sed failed"
+ # maruku fails, resorting to default markdown implementation
+ sed -i -e '/maruku/d' .yardopts || die "sed failed"
+
+ sed -i -e '/s.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc ; then
+ yard || die "yard failed"
+ fi
+}