summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-09-19 07:42:49 +0200
committerHans de Graaff <graaff@gentoo.org>2017-09-19 07:42:49 +0200
commit482ab5048e471d4ce8745fd00cf0ee7d6a31749c (patch)
tree7d12fde7f7e9a80dc646e95177f87be5c1c25afc /dev-ruby/ox/ox-2.7.0.ebuild
parentdev-ruby/ox: cleanup (diff)
downloadgentoo-482ab5048e471d4ce8745fd00cf0ee7d6a31749c.tar.gz
gentoo-482ab5048e471d4ce8745fd00cf0ee7d6a31749c.tar.bz2
gentoo-482ab5048e471d4ce8745fd00cf0ee7d6a31749c.zip
dev-ruby/ox: add 2.7.0
Package-Manager: Portage-2.3.8, Repoman-2.3.2
Diffstat (limited to 'dev-ruby/ox/ox-2.7.0.ebuild')
-rw-r--r--dev-ruby/ox/ox-2.7.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/ox/ox-2.7.0.ebuild b/dev-ruby/ox/ox-2.7.0.ebuild
new file mode 100644
index 000000000000..d51d9aa48d25
--- /dev/null
+++ b/dev-ruby/ox/ox-2.7.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A fast XML parser and Object marshaller"
+HOMEPAGE="http://www.ohler.com/ox/ https://github.com/ohler55/ox"
+SRC_URI="https://github.com/ohler55/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+
+KEYWORDS="~amd64 ~ppc64 ~x86"
+SLOT="0"
+IUSE=""
+
+each_ruby_configure() {
+ ${RUBY} -Cext/ox extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/ox
+ cp ext/ox/ox$(get_modname) lib/ox/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} test/tests.rb || die
+}