summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-08-25 08:03:16 +0200
committerHans de Graaff <graaff@gentoo.org>2017-08-25 08:03:16 +0200
commit8f505fdb58beced360e20fb83a3714e7df542f63 (patch)
treede9213eaba4089e952e8d6d277958b18e957d9f4 /dev-ruby/pg/pg-0.18.4.ebuild
parentdev-ruby/pg_array_parser: cleanup (diff)
downloadgentoo-8f505fdb58beced360e20fb83a3714e7df542f63.tar.gz
gentoo-8f505fdb58beced360e20fb83a3714e7df542f63.tar.bz2
gentoo-8f505fdb58beced360e20fb83a3714e7df542f63.zip
dev-ruby/pg: cleanup
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ruby/pg/pg-0.18.4.ebuild')
-rw-r--r--dev-ruby/pg/pg-0.18.4.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/dev-ruby/pg/pg-0.18.4.ebuild b/dev-ruby/pg/pg-0.18.4.ebuild
deleted file mode 100644
index 17f96591f7e2..000000000000
--- a/dev-ruby/pg/pg-0.18.4.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-# ruby19 test fail
-USE_RUBY="ruby20 ruby21 ruby22"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="ChangeLog Contributors.rdoc README.rdoc History.rdoc"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="Ruby extension library providing an API to PostgreSQL"
-HOMEPAGE="https://bitbucket.org/ged/ruby-pg/"
-
-LICENSE="|| ( GPL-2 Ruby )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RDEPEND+=" dev-db/postgresql:*"
-DEPEND+=" dev-db/postgresql
- test? ( >=dev-db/postgresql-9.4[server,threads] )"
-
-ruby_add_bdepend "
- doc? (
- dev-ruby/hoe
- || ( >=dev-ruby/yard-0.6.1 dev-ruby/rdoc ) )"
-
-all_ruby_prepare() {
- # hack the Rakefile to make it sure that it doesn't load
- # rake-compiler (so that we don't have to depend on it and it
- # actually works when building with USE=doc).
- sed -i \
- -e '/Rakefile.cross/s:^:#:' \
- -e '/ExtensionTask/,/^end$/ s:^:#:' \
- Rakefile || die
-}
-
-each_ruby_configure() {
- ${RUBY} -C ext extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- emake V=1 -C ext CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
- cp ext/*$(get_libname) lib || die
-}
-
-each_ruby_test() {
- if [[ "${EUID}" -ne "0" ]]; then
- # Make the rspec call explicit, this way we don't have to depend
- # on rake-compiler (nor rubygems) _and_ we don't have to rebuild
- # the whole extension from scratch.
- RSPEC_VERSION=3 ruby-ng_rspec
- else
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
- fi
-}