summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-06-02 06:27:55 +0200
committerHans de Graaff <graaff@gentoo.org>2017-06-02 06:27:55 +0200
commit78792a41df293bfabb7f50508d14ed8a44eb8742 (patch)
treec14faeee11483ddda6cb64c22def94386336262c /dev-ruby/pkg-config/pkg-config-1.2.3.ebuild
parentdev-python/ddt: Version bump to 1.1.1, enable tests (diff)
downloadgentoo-78792a41df293bfabb7f50508d14ed8a44eb8742.tar.gz
gentoo-78792a41df293bfabb7f50508d14ed8a44eb8742.tar.bz2
gentoo-78792a41df293bfabb7f50508d14ed8a44eb8742.zip
dev-ruby/pkg-config: add 1.2.3
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/pkg-config/pkg-config-1.2.3.ebuild')
-rw-r--r--dev-ruby/pkg-config/pkg-config-1.2.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/pkg-config/pkg-config-1.2.3.ebuild b/dev-ruby/pkg-config/pkg-config-1.2.3.ebuild
new file mode 100644
index 000000000000..b6263153de87
--- /dev/null
+++ b/dev-ruby/pkg-config/pkg-config-1.2.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc NEWS"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pkg-config implementation by Ruby"
+HOMEPAGE="https://github.com/rcairo/pkg-config"
+LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+# this is used for testing
+DEPEND+=" test? ( x11-libs/cairo )"
+
+all_ruby_prepare() {
+ # drop failing tests
+ sed -i -e "/test_cflags/,/end/d"\
+ -e "/test_cflags_only_I/,/end/d" test/test_pkg_config.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_${PN/-/_}.rb || die
+}