summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-09-28 07:10:25 +0200
committerHans de Graaff <graaff@gentoo.org>2019-09-28 07:45:26 +0200
commitfd591cd09b44a797fc774294b6571f7007270a27 (patch)
tree3ca80cebc68640e2fd5bdd9eb0f48e8682ffaee7 /dev-ruby/pkg-config
parentgames-emulation/mupen64plus-core: Drop old (2.5) (diff)
downloadgentoo-fd591cd09b44a797fc774294b6571f7007270a27.tar.gz
gentoo-fd591cd09b44a797fc774294b6571f7007270a27.tar.bz2
gentoo-fd591cd09b44a797fc774294b6571f7007270a27.zip
dev-ruby/pkg-config: add 1.3.9
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/pkg-config')
-rw-r--r--dev-ruby/pkg-config/Manifest1
-rw-r--r--dev-ruby/pkg-config/pkg-config-1.3.9.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/pkg-config/Manifest b/dev-ruby/pkg-config/Manifest
index 00c14c0a3d62..bbf240424fa2 100644
--- a/dev-ruby/pkg-config/Manifest
+++ b/dev-ruby/pkg-config/Manifest
@@ -1,3 +1,4 @@
DIST pkg-config-1.2.8.gem 20480 BLAKE2B cc11b5eff30f0f5e1a91e64902931ed540da108fd326fe731b71527c9c4310f55e9002617e1baae4f71a4b705b20cf10f6fa112f8ef56971e82868145d372a47 SHA512 d83a599a48c7d404946054c6846b6cfd9fce2a264c288519a6eccd9787f05d45397dd46300bf97c80700921456318154ea6d44ba32cd159803471073c2a2b065
DIST pkg-config-1.3.7.gem 20992 BLAKE2B 4927cbe744b88e11ece71e554b07092d671a1b0775aa0c647abab6718c1903b888d98aa97ce5eae89033c13a542e45880b28fc886225c226d6e525c0004ec05f SHA512 cceef2b8f0b92582256660f50be21b446e6ef8ca9edd3c7736d2dbcbf2bf8ab60a1ef8f2fed21448d01ab155fd92fe9a3e8cf1f8bda4f80a8e0a8896f1eedd60
DIST pkg-config-1.3.8.gem 21504 BLAKE2B 6959487c26b562978e00c4f6b7362c84f78f83e3ad2821b27a23feb76d1bc948832d898b81cd1347a3dec0d04bce0abf427df96420280ec721ded45619339361 SHA512 893b8804abbc295bb678e539a22c23f4bac571b5d29cdeb825f0ed2b6be1efa7f50403b97718b38034bc3d1e5bc709d9fa6e26894fb90fe0d6789b8bcc4f19ee
+DIST pkg-config-1.3.9.gem 22016 BLAKE2B bb22881e07a251722e5e2344a8ebfea105456c4994da01b6cad53b93c5fab515537c04166be9985bac224944e89506040a2f89886f03c9f5d9c2227551e6e840 SHA512 ffec47956f59daea7eefe749474389cc43b500251b7d35cf268caed975d4b8483990c6c5cc0eb1cb918a7e09edd483fe88d6e7141c13496edeb4d4aac5ab3019
diff --git a/dev-ruby/pkg-config/pkg-config-1.3.9.ebuild b/dev-ruby/pkg-config/pkg-config-1.3.9.ebuild
new file mode 100644
index 000000000000..a8f0cfce739b
--- /dev/null
+++ b/dev-ruby/pkg-config/pkg-config-1.3.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc NEWS"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pkg-config implementation by Ruby"
+HOMEPAGE="https://github.com/rcairo/pkg-config"
+LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+# this is used for testing
+DEPEND+=" test? ( x11-libs/cairo )"
+
+all_ruby_prepare() {
+ # drop failing tests
+ sed -i -e "/test_cflags/,/end/d"\
+ -e "/test_cflags_only_I/,/end/d" test/test_pkg_config.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_${PN/-/_}.rb || die
+}