summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/poltergeist
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/poltergeist')
-rw-r--r--dev-ruby/poltergeist/Manifest1
-rw-r--r--dev-ruby/poltergeist/metadata.xml8
-rw-r--r--dev-ruby/poltergeist/poltergeist-1.6.0.ebuild42
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-ruby/poltergeist/Manifest b/dev-ruby/poltergeist/Manifest
new file mode 100644
index 000000000000..9ce8911af891
--- /dev/null
+++ b/dev-ruby/poltergeist/Manifest
@@ -0,0 +1 @@
+DIST poltergeist-1.6.0.tar.gz 147447 SHA256 6a62976b6c1364be817c87daf84830d50284e3d693d8c9155d74514755d86c29 SHA512 298af6798095d78cd662dd58231ababec4a3b9925dd7d45ebb9d28c1211a3838605ba5c2ed75033439dc28d7ef84060407495e87e2fe248b1965bd3f5ccd8250 WHIRLPOOL 162e4aa97da121dd392f333550032657a199ab27225b76ed05f2f0e04e9c2c2971932fb48117ecd72f144ba194ab35c317afca1041fedf066697368f8a3429df
diff --git a/dev-ruby/poltergeist/metadata.xml b/dev-ruby/poltergeist/metadata.xml
new file mode 100644
index 000000000000..da30dce96a05
--- /dev/null
+++ b/dev-ruby/poltergeist/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">jonleighton/poltergeist</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/poltergeist/poltergeist-1.6.0.ebuild b/dev-ruby/poltergeist/poltergeist-1.6.0.ebuild
new file mode 100644
index 000000000000..291bf18a66a1
--- /dev/null
+++ b/dev-ruby/poltergeist/poltergeist-1.6.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+# There are tests but they require several unpackaged dependencies.
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A PhantomJS driver for Capybara"
+HOMEPAGE="https://github.com/jonleighton/poltergeist"
+SRC_URI="https://github.com/jonleighton/poltergeist/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND+=" www-client/phantomjs"
+
+ruby_add_rdepend ">=dev-ruby/cliver-0.3.1
+ dev-ruby/multi_json
+ >=dev-ruby/capybara-2.1
+ >=dev-ruby/websocket-driver-0.2.0"
+
+all_ruby_prepare() {
+ # Fix cliver versioning to accept all 0.x versions
+ sed -i -e 's/0.3.1/0.3/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
+
+ # Remove integration tests for now since they require additional dependencies.
+ rm -rf spec/integration
+}