summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-08-14 08:29:26 +0200
committerHans de Graaff <graaff@gentoo.org>2021-08-14 08:29:26 +0200
commit6267f39a1208d18d19295f174e4387329b383f9c (patch)
tree2b7df3c789bb5804866c81ce386df32cdf6cff4a /dev-ruby/pundit
parentdev-util/clion: add missing deps to 2021.2 (diff)
downloadgentoo-6267f39a1208d18d19295f174e4387329b383f9c.tar.gz
gentoo-6267f39a1208d18d19295f174e4387329b383f9c.tar.bz2
gentoo-6267f39a1208d18d19295f174e4387329b383f9c.zip
dev-ruby/pundit: add 2.1.1
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/pundit')
-rw-r--r--dev-ruby/pundit/Manifest1
-rw-r--r--dev-ruby/pundit/pundit-2.1.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/pundit/Manifest b/dev-ruby/pundit/Manifest
index c2f78d85585d..7b6e5ce6f7ef 100644
--- a/dev-ruby/pundit/Manifest
+++ b/dev-ruby/pundit/Manifest
@@ -1 +1,2 @@
DIST pundit-2.1.0.gem 25600 BLAKE2B f8284e326a68475fe4c733de85597ba91e376d37e5dd24d97c1a8da2ab7f15d2cf35cf76688370f1a96c00f8ce89df2d2bb6b3c6de1ae33d6cdfe1ffd1926e3f SHA512 3201cb3acca8301a0e07fa9bd58617ee32074842e873a85a31d9b56fac5bd93c4a78d94d8b57556a011f1713712eb484ef3281d68ae3acf1c8bf1bce13f47e0c
+DIST pundit-2.1.1.gem 26112 BLAKE2B de517b25d0d062c2a85b6ca28b6dc8ebcea25f4786435788e90394ad29338462073c946d7127172766baeced6dc98d0e21923220b1371861f200b73fe09039e9 SHA512 d5463e21801ef04e82500c671ccbee0e8fb1576a8b7b86283ecc80d1c6e81cd375abf3c81ee5fad8323eb3ba0c296df43c9a78fafc2cd6e7797f1447d02ede0d
diff --git a/dev-ruby/pundit/pundit-2.1.1.ebuild b/dev-ruby/pundit/pundit-2.1.1.ebuild
new file mode 100644
index 000000000000..aabad7105e01
--- /dev/null
+++ b/dev-ruby/pundit/pundit-2.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Object oriented authorization for Rails applications"
+HOMEPAGE="https://github.com/elabs/pundit https://rubygems.org/gems/pundit"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activesupport-3.0.0:*"
+
+ruby_add_bdepend "test? ( >=dev-ruby/actionpack-3.0.0
+ >=dev-ruby/activemodel-3.0.0 )"
+
+all_ruby_prepare() {
+ sed -i -e "/pry/d" spec/spec_helper.rb || die
+}