summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-06 17:10:21 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-06 17:19:52 -0500
commit0291e85c3036808e121507ef10fdbbcd59b1aa4d (patch)
tree428837fee336381e02a54653c333b4c3fd06081c /dev-ruby/puppetdb-termini
parentapp-admin/puppetdb: 6.3.0 bump (diff)
downloadgentoo-0291e85c3036808e121507ef10fdbbcd59b1aa4d.tar.gz
gentoo-0291e85c3036808e121507ef10fdbbcd59b1aa4d.tar.bz2
gentoo-0291e85c3036808e121507ef10fdbbcd59b1aa4d.zip
dev-ruby/puppetdb-termini: 6.3.0 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby/puppetdb-termini')
-rw-r--r--dev-ruby/puppetdb-termini/Manifest1
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-6.3.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/Manifest b/dev-ruby/puppetdb-termini/Manifest
index 0568c0196ae9..304364af34c0 100644
--- a/dev-ruby/puppetdb-termini/Manifest
+++ b/dev-ruby/puppetdb-termini/Manifest
@@ -1,3 +1,4 @@
DIST puppetdb-termini_5.2.4-1xenial_all.deb 20538 BLAKE2B aad000bc0e13e3c97f4428bca88653cbfd76db2e5499f2acad90afcff58847e1dbaec9bc9ae8ec30e21c9b5c8308061b7d51058f0a17e2936d6dfd05ccc650f4 SHA512 98e871a4867735a8ca677ee3fbb6ab5e8718e78623fe6d497a3c680e090b86a0cefc35ee318f6f5abb45ebfd02d9bf75a04f0f1fc48ba654443c5c4ca99f3180
DIST puppetdb-termini_5.2.7-1xenial_all.deb 20560 BLAKE2B def7bb25badadd2880589d5708e8b9a0f87033977a21ee65fca7b27caf8c3568c66cf7f21123ecd8dd037e29023e65a9393d8b3608ffe0e021f9aad5a8c66755 SHA512 b5a5b4c721a35d95093d9da757f5a2dcfcc232343b6ca6dcf7184a20f9ff305a9c2f04328e17a0e02579d6ee7245c7c9b7e9ba8d22bc8f3bc1c13cf50c784101
DIST puppetdb-termini_6.2.0-1stretch_all.deb 20602 BLAKE2B 6f51e8f6d87df992ced0ccc23c1cecd26a1fd2b3ad2b1d507b22d3f555fafd754913f50aa7840f40cb8c3cdcabfd4af84411213842d4a70105c69d9a8fe55eaf SHA512 ec73ee1514d6217e57672936d775974911bee7135af95d95e58f60c723d8e8760b005cb2a214fdfe692acd807e07ae53ba396bcf5f990c77d9a07ca485a784c1
+DIST puppetdb-termini_6.3.0-1stretch_all.deb 20662 BLAKE2B a4910a210db12afe2aa2ff455580497ce685b4a9924da6fa12e6013e73512b384e7231749afaf78ee68839f5413551ffa427cc06daef20eb8bf6476bbabb2147 SHA512 91640ff4a5b845bf6e50ccdf850c7825fcc7eb4ca1e9f2547931012b3d09cb00e3733dc10e2a6b447143822d3c2bf6b80f862a6418331e0ef0c08b873c3351a1
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-6.3.0.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-6.3.0.ebuild
new file mode 100644
index 000000000000..6d51b944dfdb
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-6.3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="http://docs.puppetlabs.com/puppetdb/"
+SRC_URI="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}