summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-01-16 11:25:36 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-01-16 11:25:36 -0600
commit035a294e47f58842549fb7c8984f31234b4a85a2 (patch)
tree2961cba877df29182778f9907387a0b2c513db55 /dev-ruby/puppetdb-termini
parentapp-admin/puppetserver: 6.8.0 bump (diff)
downloadgentoo-035a294e47f58842549fb7c8984f31234b4a85a2.tar.gz
gentoo-035a294e47f58842549fb7c8984f31234b4a85a2.tar.bz2
gentoo-035a294e47f58842549fb7c8984f31234b4a85a2.zip
dev-ruby/puppetdb-termini: 6.8.0 bump
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby/puppetdb-termini')
-rw-r--r--dev-ruby/puppetdb-termini/Manifest1
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-6.8.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/Manifest b/dev-ruby/puppetdb-termini/Manifest
index 85f2415598da..85da28d45d89 100644
--- a/dev-ruby/puppetdb-termini/Manifest
+++ b/dev-ruby/puppetdb-termini/Manifest
@@ -1 +1,2 @@
DIST puppetdb-termini_6.7.2-1stretch_all.deb 21298 BLAKE2B 4f4af664b45385487061c26051060d2fae668e80841e48a7a2db899769ca7cdad84bd7956fd1806526db307a42604bb3fa3e686d6c960a3c7c760286f39e794c SHA512 7e3279b4e82ddece9350399cd1579bb0297f235c5003c93dc37aa23ae81bd1efd83739de5fc2634cc0fccfd222e8eb0603c622acabdce968fa05252c5ae8747f
+DIST puppetdb-termini_6.8.0-1stretch_all.deb 21302 BLAKE2B d3524f7acfb60ba73ca5ec42d3d4f2c79efb944ad597e97b664dd7925f24aa80905b2fa7f8dfb98ef7da777242f34d36711affabb179b005703bed8e5d4b33e3 SHA512 8d92e9bffe8e377823b644a54aa73e59c32cf1a69b2b97b9bbf61d9e5149f31c03bb5d39175844f2651a33f6028d44bf0eb6dc2e3ac3236faab9f11a801d4981
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-6.8.0.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-6.8.0.ebuild
new file mode 100644
index 000000000000..a7f2b53b2dde
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-6.8.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="http://docs.puppetlabs.com/puppetdb/"
+SRC_URI="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}