summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-11-24 07:59:16 +0100
committerHans de Graaff <graaff@gentoo.org>2015-11-24 07:59:49 +0100
commit5271c9199a2d6b24bb3b3756a5f6f46e779dee95 (patch)
tree8d9372714d6a7b5a5a1c9c14c57b56f95513838e /dev-ruby/rack/rack-1.6.2.ebuild
parentdev-ruby/highline: cleanup (diff)
downloadgentoo-5271c9199a2d6b24bb3b3756a5f6f46e779dee95.tar.gz
gentoo-5271c9199a2d6b24bb3b3756a5f6f46e779dee95.tar.bz2
gentoo-5271c9199a2d6b24bb3b3756a5f6f46e779dee95.zip
dev-ruby/rack: cleanup
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-ruby/rack/rack-1.6.2.ebuild')
-rw-r--r--dev-ruby/rack/rack-1.6.2.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-ruby/rack/rack-1.6.2.ebuild b/dev-ruby/rack/rack-1.6.2.ebuild
deleted file mode 100644
index ca62a17267fb..000000000000
--- a/dev-ruby/rack/rack-1.6.2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21 ruby22"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="HISTORY.md KNOWN-ISSUES README.rdoc SPEC"
-
-inherit ruby-fakegem eutils versionator
-
-DESCRIPTION="A modular Ruby webserver interface"
-HOMEPAGE="https://rack.github.com/"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RUBY_PATCHES=( ${PN}-1.2.1-gentoo.patch )
-
-ruby_add_rdepend "virtual/ruby-ssl"
-
-# The gem has automagic dependencies over mongrel, ruby-openid,
-# memcache-client, thin, mongrel and camping; not sure if we should
-# make them dependencies at all.
-ruby_add_bdepend "test? ( dev-ruby/bacon )"
-
-# Block against versions in older slots that also try to install a binary.
-RDEPEND="${RDEPEND} !<dev-ruby/rack-1.4.5-r1:1.4 !<dev-ruby/rack-1.5.2-r4:1.5"
-
-all_ruby_prepare() {
- # The build system tries to generate the ChangeLog from git. Create
- # an empty file to avoid a needless dependency on git.
- touch ChangeLog || die
-}
-
-each_ruby_test() {
- # Since the Rakefile calls specrb directly rather than loading it, we
- # cannot use it to launch the tests or only the currently-selected
- # RUBY interpreter will be tested.
- ${RUBY} -S bacon -Ilib -w -a \
- -q -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|Rack::Server)' \
- || die "test failed for ${RUBY}"
-}