summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-05-09 06:46:10 +0200
committerHans de Graaff <graaff@gentoo.org>2016-05-09 06:46:10 +0200
commitc244e67b27710a9e6c75045c96a87de47b8c314d (patch)
tree134576f2dc212137f45a77ba7f728f3b2f753a1d /dev-ruby/rails-dom-testing
parentgnome-base/librsvg: Stable for HPPA PPC64 (bug #581948). (diff)
downloadgentoo-c244e67b27710a9e6c75045c96a87de47b8c314d.tar.gz
gentoo-c244e67b27710a9e6c75045c96a87de47b8c314d.tar.bz2
gentoo-c244e67b27710a9e6c75045c96a87de47b8c314d.zip
dev-ruby/rails-dom-testing: add 2.0.0
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/rails-dom-testing')
-rw-r--r--dev-ruby/rails-dom-testing/Manifest1
-rw-r--r--dev-ruby/rails-dom-testing/rails-dom-testing-2.0.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/rails-dom-testing/Manifest b/dev-ruby/rails-dom-testing/Manifest
index 631de04a52b7..7dbab10dc097 100644
--- a/dev-ruby/rails-dom-testing/Manifest
+++ b/dev-ruby/rails-dom-testing/Manifest
@@ -1 +1,2 @@
DIST rails-dom-testing-1.0.7.gem 17408 SHA256 6813821425ff44ae3188162d0bae1a2ae08080fc1a584860bf78d50190a112ed SHA512 29999b404e1c0ab8dea2f173feff606c57646fc893be53496d2972b6afbd3b010c0238cfc7be39c088ef2f8ab6421a7ddad5a5b5da2646264a5a7c33d650a26b WHIRLPOOL 47b3fe998bd3d3b008e5c7b70736c633316e47c7de5fbfe774dfa4aa45b72dbe4f05bc380fe3cb5d012ec8ff6e818a44d544b67f83c6ed99ee24f1ec80c876e1
+DIST rails-dom-testing-2.0.0.gem 13824 SHA256 dfe5b894167bdb5dcd24e679a6efe8bb03ca471ed7237b1f873920cfaaa730ea SHA512 87c01525487bf8f7c76f250a3732e9608954f1c96f02ff4aed7011db760f299221cba78abd68a0b8016d7478ce695fa86c028e433e3014797aa439feaa63b89f WHIRLPOOL 627cd589009c869176e1b88207f3335bf1eb1a475183e14217e3fd813b2dbc3dcc013a519519ea77dbfcff41f741b117975a74b327a9ead85cb660cc14f61a9f
diff --git a/dev-ruby/rails-dom-testing/rails-dom-testing-2.0.0.ebuild b/dev-ruby/rails-dom-testing/rails-dom-testing-2.0.0.ebuild
new file mode 100644
index 000000000000..b3bcccf924ff
--- /dev/null
+++ b/dev-ruby/rails-dom-testing/rails-dom-testing-2.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Compare doms and assert certain elements exists in doms using Nokogiri"
+HOMEPAGE="https://github.com/kaspth/rails-dom-testing"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/activesupport-4.2:* <dev-ruby/activesupport-6.0:*
+ >=dev-ruby/nokogiri-1.6.0 =dev-ruby/nokogiri-1.6*"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/*_test.rb"].each{|f| require f}' || die
+}