summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-08-31 09:57:20 +0200
committerHans de Graaff <graaff@gentoo.org>2019-08-31 10:09:05 +0200
commit8a97c2b0beb9d44d97db3ea5c5f51b702cdbad4d (patch)
tree8543e949049c595f6543645db524d7ade1628d7d /dev-ruby/rails/rails-6.0.0.ebuild
parentdev-ruby/actiontext: initial import of 6.0.0 (diff)
downloadgentoo-8a97c2b0beb9d44d97db3ea5c5f51b702cdbad4d.tar.gz
gentoo-8a97c2b0beb9d44d97db3ea5c5f51b702cdbad4d.tar.bz2
gentoo-8a97c2b0beb9d44d97db3ea5c5f51b702cdbad4d.zip
dev-ruby/rails: add 6.0.0
This release drops the "asset-pipeline" USE flag since it is no longer obvious what should be included in a default rails asset pipeline, given the variations in legacy applications versus new applications and people's preferences on what to use. Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rails/rails-6.0.0.ebuild')
-rw-r--r--dev-ruby/rails/rails-6.0.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/rails/rails-6.0.0.ebuild b/dev-ruby/rails/rails-6.0.0.ebuild
new file mode 100644
index 000000000000..50c9c59c9ee6
--- /dev/null
+++ b/dev-ruby/rails/rails-6.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="https://rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+
+IUSE=""
+
+ruby_add_rdepend "
+ ~dev-ruby/actioncable-${PV}
+ ~dev-ruby/actionmailbox-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/actiontext-${PV}
+ ~dev-ruby/actionview-${PV}
+ ~dev-ruby/activejob-${PV}
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activestorage-${PV}
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/railties-${PV}
+ >=dev-ruby/bundler-1.3
+ >=dev-ruby/sprockets-rails-2.0.0:*
+"