summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-12-23 17:25:05 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-12-23 22:28:59 +0100
commitcc1a4c1e750bd9fed55c16abf08b85ca8a3d6313 (patch)
treea0c83aed8d0937900dc6303acd630d5b468b0835 /dev-ruby/rb-gsl
parentnet-misc/freerdp: set COMMIT (diff)
downloadgentoo-cc1a4c1e750bd9fed55c16abf08b85ca8a3d6313.tar.gz
gentoo-cc1a4c1e750bd9fed55c16abf08b85ca8a3d6313.tar.bz2
gentoo-cc1a4c1e750bd9fed55c16abf08b85ca8a3d6313.zip
dev-ruby/rb-gsl: Version bump to 2.1.0.1
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-ruby/rb-gsl')
-rw-r--r--dev-ruby/rb-gsl/Manifest1
-rw-r--r--dev-ruby/rb-gsl/files/rb-gsl-2.1.0.1-narray-superclass.patch26
-rw-r--r--dev-ruby/rb-gsl/rb-gsl-2.1.0.1.ebuild49
3 files changed, 76 insertions, 0 deletions
diff --git a/dev-ruby/rb-gsl/Manifest b/dev-ruby/rb-gsl/Manifest
index fbeac69a16d5..1f7beafc1fc1 100644
--- a/dev-ruby/rb-gsl/Manifest
+++ b/dev-ruby/rb-gsl/Manifest
@@ -1 +1,2 @@
DIST gsl-1.16.0.6.gem 594944 SHA256 3fa354277d68a729e239a8c9eb3408f2978a444b7da3708cff120a9cb69cdcff SHA512 99610ef7e9b57c29f1972c4cb2853642157660b885a0a9761876c649badeb02dace7f0191453ce63d1a7f59bc3ee89fb61a73ae71522b5430f7916a60c4d1490 WHIRLPOOL e2b0c71e5262242586e02ffba632978057a0a467171974a0acab9e43e0f268741815b93a43a573dbffa56fe8448b95d909622207dba2f52ecb231d92abc648b2
+DIST gsl-2.1.0.1.gem 729600 SHA256 3701f85cc161c454e4876cc805200cf0973192ab52e808ba6230ab3d08fd64f1 SHA512 e07056b9989f5dd8ee06df02cf548607ae06af1e347eec7c5a50ad69bac51ab642b10d5b7e8bbd8d77666aba9cf6985145ac3b23d02489ed616bfa884dbf96f4 WHIRLPOOL 8afc8ba125b9e17d46495dcc4c8f58ea3cce77524ee40bce23be0016ccea5d502eaa81e05e28496f7e8764372f3df37812eaebde2cdcd91e82dfa8c70905ef5b
diff --git a/dev-ruby/rb-gsl/files/rb-gsl-2.1.0.1-narray-superclass.patch b/dev-ruby/rb-gsl/files/rb-gsl-2.1.0.1-narray-superclass.patch
new file mode 100644
index 000000000000..4af8042452f1
--- /dev/null
+++ b/dev-ruby/rb-gsl/files/rb-gsl-2.1.0.1-narray-superclass.patch
@@ -0,0 +1,26 @@
+From 9e0c9e6f0a509b39c68fbaf6657260c6b122bb1b Mon Sep 17 00:00:00 2001
+From: Sameer Deshmukh <sameer.deshmukh93@gmail.com>
+Date: Thu, 12 May 2016 04:57:06 +0530
+Subject: [PATCH] fix narray superclass mismatch problem
+
+---
+ lib/gsl.rb | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/lib/gsl.rb b/lib/gsl.rb
+index 3c67741..aba8f2d 100644
+--- a/lib/gsl.rb
++++ b/lib/gsl.rb
+@@ -1,10 +1,10 @@
+ begin
+- require 'narray'
++ require 'narray' if ENV['NARRAY']
+ rescue LoadError
+ end
+
+ begin
+- require 'nmatrix/nmatrix'
++ require 'nmatrix/nmatrix' if ENV['NMATRIX']
+ rescue LoadError
+ end
+
diff --git a/dev-ruby/rb-gsl/rb-gsl-2.1.0.1.ebuild b/dev-ruby/rb-gsl/rb-gsl-2.1.0.1.ebuild
new file mode 100644
index 000000000000..52f93c3e3ad6
--- /dev/null
+++ b/dev-ruby/rb-gsl/rb-gsl-2.1.0.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_NAME="gsl"
+inherit ruby-fakegem multilib
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.md"
+
+DESCRIPTION="Ruby interface to GNU Scientific Library"
+HOMEPAGE="https://github.com/SciRuby/rb-gsl"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND+=" >=sci-libs/gsl-2.3[deprecated]"
+RDEPEND+=" >=sci-libs/gsl-2.3[deprecated]"
+
+RUBY_S="${PN}-${P}"
+
+RUBY_PATCHES=( "${FILESDIR}"/${P}-narray-superclass.patch )
+
+ruby_add_bdepend "dev-ruby/narray"
+ruby_add_rdepend "dev-ruby/narray"
+
+all_ruby_prepare() {
+ sed -i -e '/LOCAL_LIBS/ s: -l: -L#{path.gsub("ext", "lib")} -l:' ext/gsl_native/extconf.rb || die
+ # nmatrix only tests
+ rm -r test/gsl/nmatrix_tests || die
+}
+
+each_ruby_configure() {
+ NARRAY=1 ${RUBY} -Cext/gsl_native extconf.rb || die
+}
+
+each_ruby_compile() {
+ NARRAY=1 emake -Cext/gsl_native V=1
+ cp ext/gsl_native/*$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ NARRAY=1 ${RUBY} -Ilib:test:. -e 'Dir["test/**/*_test.rb"].each{|f| require f}' || die
+}