summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-10 15:23:29 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-10 15:24:16 +0200
commite6c791da83926c82871cdf301bbdf18bb7a4d3f8 (patch)
tree04ae869d9bb7b0b6e2f79c9ff0282e0f74f571c6 /dev-ruby/rbst
parentros-meta/audio_common: Bump to 0.3.7. (diff)
downloadgentoo-e6c791da83926c82871cdf301bbdf18bb7a4d3f8.tar.gz
gentoo-e6c791da83926c82871cdf301bbdf18bb7a4d3f8.tar.bz2
gentoo-e6c791da83926c82871cdf301bbdf18bb7a4d3f8.zip
dev-ruby/rbst: Bump to 0.6.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-ruby/rbst')
-rw-r--r--dev-ruby/rbst/Manifest1
-rw-r--r--dev-ruby/rbst/rbst-0.6.5.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-ruby/rbst/Manifest b/dev-ruby/rbst/Manifest
index 178c9b36d7e8..6b475f235b83 100644
--- a/dev-ruby/rbst/Manifest
+++ b/dev-ruby/rbst/Manifest
@@ -1 +1,2 @@
DIST rbst-0.5.1.tar.gz 14039 BLAKE2B 7399e92f98c650842464ea9240775ad776ec8d574c578d8da764778bbe8050be429e2521df82b3b04a0bf9cd18bef4f114890d54ef8d6f34c797f0f2f2e35bc2 SHA512 a7fffc1ccf495c1858d6d9fadd38a4d6a2c27a2da8eda8dad038f4ab881f4521223a35f97d4018d25b32c2621132a623040ba930494b36e1385356ecb87fecdc
+DIST rbst-0.6.5.tar.gz 15760 BLAKE2B 3bace4401c8c92eba286f242c1e074aa833094c21e4b00bfa2eee982ad8cbb94024dda2210eb1c72ab88293b1a63a62a5bdeafde2615b0430bd0a7cc21ced14c SHA512 2d4a28c70a4925e1ffe0cd2ff10c275f67cae4a918c1064bd73cb8e7e490be251acff09670d78fef1edeb1a7dab8995aa0b4737563a0797ff66c0fee3f89bba2
diff --git a/dev-ruby/rbst/rbst-0.6.5.ebuild b/dev-ruby/rbst/rbst-0.6.5.ebuild
new file mode 100644
index 000000000000..4dd5c2e9ee65
--- /dev/null
+++ b/dev-ruby/rbst/rbst-0.6.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_NAME="RbST"
+RUBY_FAKEGEM_GEMSPEC="RbST.gemspec"
+
+inherit python-single-r1 ruby-fakegem
+
+DESCRIPTION="A simple Ruby wrapper for processing rST via docutils"
+HOMEPAGE="https://github.com/alphabetum/rbst"
+SRC_URI="https://github.com/alphabetum/rbst/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-python/docutils
+ ${PYTHON_DEPS}"
+DEPEND="
+ test? ( ${RDEPEND} )"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/minitest-5.14.0:5
+ >=dev-ruby/mocha-1.1.0:1.0
+ )"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ ruby-ng_pkg_setup
+}
+
+all_ruby_prepare() {
+ # do not use bundler
+ sed -i -e '/bundler/,/end/d' \
+ Rakefile test/helper.rb || die
+ # do not use python2
+ sed -i -e '/python2/,/end/d' \
+ test/test_rbst.rb || die
+
+ # force our python version
+ sed -i -e "s:\(python_path=\"\)python:\1${EPYTHON}:" lib/rbst.rb || die
+ python_fix_shebang lib/rst2parts
+}