summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/rbtree
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/rbtree')
-rw-r--r--dev-ruby/rbtree/Manifest1
-rw-r--r--dev-ruby/rbtree/metadata.xml8
-rw-r--r--dev-ruby/rbtree/rbtree-0.4.2.ebuild39
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-ruby/rbtree/Manifest b/dev-ruby/rbtree/Manifest
new file mode 100644
index 000000000000..c5718838c549
--- /dev/null
+++ b/dev-ruby/rbtree/Manifest
@@ -0,0 +1 @@
+DIST rbtree-0.4.2.gem 30208 SHA256 83901c9b01de35221b8479b6b6a30572da5a16d9d404bc90eed08fa8e1d028aa SHA512 84a6cb5567e319e5ee830afb0fe4f64697a2748099e2976e85a2998123f4fe4acdadb1ee9574178576ffc5e989e15c6ce033ebcb58e24fcec9662a3feee9eb20 WHIRLPOOL 412d839bb3dbd916aa76b5be7ea4bb7597a25d4a6bfde4459b4e43124b067612c0790a8b310467c4a943090e5cdd54621426caffd230454426f274de8edd3190
diff --git a/dev-ruby/rbtree/metadata.xml b/dev-ruby/rbtree/metadata.xml
new file mode 100644
index 000000000000..837254783903
--- /dev/null
+++ b/dev-ruby/rbtree/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+<longdescription lang="en">
+RBTree is a sorted associative collection that is implemented with Red-Black Tree. The elements of RBTree are ordered and its interface is the almost same as Hash, so simply you can consider RBTree sorted Hash.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-ruby/rbtree/rbtree-0.4.2.ebuild b/dev-ruby/rbtree/rbtree-0.4.2.ebuild
new file mode 100644
index 000000000000..45ca22714c39
--- /dev/null
+++ b/dev-ruby/rbtree/rbtree-0.4.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit multilib ruby-fakegem
+
+RUBY_FAKEGEM_EXTRAINSTALL="rbtree$(get_modname)"
+
+DESCRIPTION="Ruby/RBTree module"
+HOMEPAGE="http://www.geocities.co.jp/SiliconValley-PaloAlto/3388/rbtree/README.html"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+all_ruby_prepare() {
+ # Fix test for random hash ordering.
+ sed -i -e '527 s/flatten/flatten.sort/g' test.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1
+}
+
+each_ruby_test() {
+ ${RUBY} test.rb || die
+}