summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2021-12-26 17:52:13 +0800
committerHans de Graaff <graaff@gentoo.org>2022-03-26 15:30:26 +0100
commite4752a480e4c944886310cb1defe0aee0312cead (patch)
treef22bc812aa75208215e10fe620510a8d6dfbcb9e /dev-ruby/rdoc
parentdev-ruby/sprockets: add ruby30 (diff)
downloadgentoo-e4752a480e4c944886310cb1defe0aee0312cead.tar.gz
gentoo-e4752a480e4c944886310cb1defe0aee0312cead.tar.bz2
gentoo-e4752a480e4c944886310cb1defe0aee0312cead.zip
dev-ruby/rdoc: remove the hprefixify command on shebangs.
If two ruby targets are specified, the scripts get `/usr/bin/env ruby` shebangs. "env ruby" is then replaced in the ebuilds to be "ruby${ver}" (ruby27 or ruby30). They needs to be prefixified. Contrastingly, when there is one ruby target, the shebang is the correct EPREFIX/usr/bin/ruby${ver}. No prefixify should be applied. To unify the two cases, the shebangs for the two-ruby-target case are changed to be `EPREFIX/usr/bin/env ruby`. Reference: https://github.com/gentoo/gentoo/pull/21046 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Benda Xu <heroxbd@gentoo.org> Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rdoc')
-rw-r--r--dev-ruby/rdoc/rdoc-6.3.2.ebuild3
-rw-r--r--dev-ruby/rdoc/rdoc-6.3.3-r1.ebuild3
-rw-r--r--dev-ruby/rdoc/rdoc-6.3.3.ebuild3
3 files changed, 3 insertions, 6 deletions
diff --git a/dev-ruby/rdoc/rdoc-6.3.2.ebuild b/dev-ruby/rdoc/rdoc-6.3.2.ebuild
index 44aab8aec7e4..be4d9995ff2f 100644
--- a/dev-ruby/rdoc/rdoc-6.3.2.ebuild
+++ b/dev-ruby/rdoc/rdoc-6.3.2.ebuild
@@ -13,7 +13,7 @@ RUBY_FAKEGEM_BINDIR="exe"
RUBY_FAKEGEM_GEMSPEC="rdoc.gemspec"
-inherit prefix ruby-fakegem
+inherit ruby-fakegem
DESCRIPTION="An extended version of the RDoc library from Ruby 1.8"
HOMEPAGE="https://github.com/ruby/rdoc/"
@@ -82,7 +82,6 @@ all_ruby_install() {
ruby_fakegem_binwrapper $bin /usr/bin/${bin}${version}
sed -i -e "1s/env ruby/ruby${version}/" \
"${ED}/usr/bin/${bin}${version}" || die
- use prefix && hprefixify "${ED}/usr/bin/${bin}${version}"
fi
done
done
diff --git a/dev-ruby/rdoc/rdoc-6.3.3-r1.ebuild b/dev-ruby/rdoc/rdoc-6.3.3-r1.ebuild
index c77b59a31571..feff109f3ce8 100644
--- a/dev-ruby/rdoc/rdoc-6.3.3-r1.ebuild
+++ b/dev-ruby/rdoc/rdoc-6.3.3-r1.ebuild
@@ -13,7 +13,7 @@ RUBY_FAKEGEM_BINDIR="exe"
RUBY_FAKEGEM_GEMSPEC="rdoc.gemspec"
-inherit prefix ruby-fakegem
+inherit ruby-fakegem
DESCRIPTION="An extended version of the RDoc library from Ruby 1.8"
HOMEPAGE="https://github.com/ruby/rdoc/"
@@ -82,7 +82,6 @@ all_ruby_install() {
ruby_fakegem_binwrapper $bin /usr/bin/${bin}${version}
sed -i -e "1s/env ruby/ruby${version}/" \
"${ED}/usr/bin/${bin}${version}" || die
- use prefix && hprefixify "${ED}/usr/bin/${bin}${version}"
fi
done
done
diff --git a/dev-ruby/rdoc/rdoc-6.3.3.ebuild b/dev-ruby/rdoc/rdoc-6.3.3.ebuild
index c0a2e2d90b56..507317f9b0a0 100644
--- a/dev-ruby/rdoc/rdoc-6.3.3.ebuild
+++ b/dev-ruby/rdoc/rdoc-6.3.3.ebuild
@@ -13,7 +13,7 @@ RUBY_FAKEGEM_BINDIR="exe"
RUBY_FAKEGEM_GEMSPEC="rdoc.gemspec"
-inherit prefix ruby-fakegem
+inherit ruby-fakegem
DESCRIPTION="An extended version of the RDoc library from Ruby 1.8"
HOMEPAGE="https://github.com/ruby/rdoc/"
@@ -82,7 +82,6 @@ all_ruby_install() {
ruby_fakegem_binwrapper $bin /usr/bin/${bin}${version}
sed -i -e "1s/env ruby/ruby${version}/" \
"${ED}/usr/bin/${bin}${version}" || die
- use prefix && hprefixify "${ED}/usr/bin/${bin}${version}"
fi
done
done