summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-01-09 08:11:52 +0100
committerHans de Graaff <graaff@gentoo.org>2022-01-09 08:11:52 +0100
commit6a9f4db5f968fa5e6e74f405b95e17749012e8c1 (patch)
tree5966478cd816e3b3bffcfe9f35906deb362beee9 /dev-ruby/regexp_property_values
parentdev-embedded/platformio: drop 5.1.1, 5.2.3-r1 (diff)
downloadgentoo-6a9f4db5f968fa5e6e74f405b95e17749012e8c1.tar.gz
gentoo-6a9f4db5f968fa5e6e74f405b95e17749012e8c1.tar.bz2
gentoo-6a9f4db5f968fa5e6e74f405b95e17749012e8c1.zip
dev-ruby/regexp_property_values: add 1.2.0
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/regexp_property_values')
-rw-r--r--dev-ruby/regexp_property_values/Manifest1
-rw-r--r--dev-ruby/regexp_property_values/regexp_property_values-1.2.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/regexp_property_values/Manifest b/dev-ruby/regexp_property_values/Manifest
index bcce9c2637b7..da806e51321b 100644
--- a/dev-ruby/regexp_property_values/Manifest
+++ b/dev-ruby/regexp_property_values/Manifest
@@ -1,2 +1,3 @@
DIST regexp_property_values-1.0.0.tar.gz 12884 BLAKE2B 82f63d21a1e1508cef79afc2f1b5cca842c1e5bc96b197efa90ec0d02e7bd213cc67ae99f4f71cae6e632e0804fa2d6e935c7d30f27a940c767f5a83dd9edd21 SHA512 f51946d93c255c3b51bfb8055d2c0548c9656db9f208de74b569df8799fa97712a76b509546e149f71e3176ae0e979f295b225c171cedc687e1871f204c1e0d3
DIST regexp_property_values-1.1.0.tar.gz 13637 BLAKE2B c274dbe0a1168af8de4f3180ba48d3332b1b4425aefa7be33074465120568aca4fc3c3ffe5caa27042139495d1d6ce80e660da4239be8455f41f7e0a97f8f357 SHA512 196b29de3d41502b1f26fb3a64ecf6135ca917b85edb633bee015fde1dfac86e00f9565509973f64842a24542740cb4a887a754b4688f47fc32b0650fc80feca
+DIST regexp_property_values-1.2.0.tar.gz 13713 BLAKE2B eaf96fea2fcaca3156f87271f772e03c07c447e7876333b7fa3f11f9bbf267d3e93d69c17601e8fa35004aa8fdb35b05829490ba86906fc4b460281ed29da561 SHA512 01add1c7ededb8a48b42d3c24b5de6d539774656bd59b666e6088b20a495e1936b547ec903678bbb8e49af35f7c72e3dbd35a7750ecba91a04c751d5900bed8a
diff --git a/dev-ruby/regexp_property_values/regexp_property_values-1.2.0.ebuild b/dev-ruby/regexp_property_values/regexp_property_values-1.2.0.ebuild
new file mode 100644
index 000000000000..485ecbe3e2ea
--- /dev/null
+++ b/dev-ruby/regexp_property_values/regexp_property_values-1.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/regexp_property_values/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR="lib/regexp_property_values"
+
+inherit ruby-fakegem
+
+DESCRIPTION="See which property values are supported by the regular expression engine"
+HOMEPAGE="https://github.com/janosch-x/regexp_property_values"
+SRC_URI="https://github.com/janosch-x/regexp_property_values/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
+
+ # Avoid dependency on character_set which would lead to circular
+ # dependencies.
+ sed -i -e '/returns a CharacterSet/askip "gentoo circular dependencies"' spec/regexp_property_values/value_spec.rb || die
+}