summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-12-07 07:41:19 +0100
committerHans de Graaff <graaff@gentoo.org>2021-12-07 07:41:19 +0100
commitfeea5144cebacc509409d595132b2d40e982df99 (patch)
treee06dbf64aee431f143e4d49293f30b04e6260f62 /dev-ruby/regexp_property_values
parentdev-ruby/regexp_property_values: amd64 stable (diff)
downloadgentoo-feea5144cebacc509409d595132b2d40e982df99.tar.gz
gentoo-feea5144cebacc509409d595132b2d40e982df99.tar.bz2
gentoo-feea5144cebacc509409d595132b2d40e982df99.zip
dev-ruby/regexp_property_values: cleanup
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/regexp_property_values')
-rw-r--r--dev-ruby/regexp_property_values/regexp_property_values-1.0.0.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-ruby/regexp_property_values/regexp_property_values-1.0.0.ebuild b/dev-ruby/regexp_property_values/regexp_property_values-1.0.0.ebuild
deleted file mode 100644
index 0b70f9fd51a3..000000000000
--- a/dev-ruby/regexp_property_values/regexp_property_values-1.0.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="See which property values are supported by the regular expression engine"
-HOMEPAGE="https://github.com/janosch-x/regexp_property_values"
-SRC_URI="https://github.com/janosch-x/regexp_property_values/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="1"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
-IUSE=""
-
-all_ruby_prepare() {
- sed -i -e 's/git ls-files -z/find -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
- sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
-
- # Avoid dependency on character_set which would lead to circular
- # dependencies.
- sed -i -e '/returns a CharacterSet/askip "gentoo circular dependencies"' spec/regexp_property_values/value_spec.rb || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/regexp_property_values extconf.rb || die
-}
-
-each_ruby_compile() {
- emake -Cext/regexp_property_values V=1
- cp ext/regexp_property_values/regexp_property_values.so lib/regexp_property_values/ || die
-}