summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/request_store
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/request_store')
-rw-r--r--dev-ruby/request_store/Manifest3
-rw-r--r--dev-ruby/request_store/metadata.xml8
-rw-r--r--dev-ruby/request_store/request_store-1.0.5.ebuild23
-rw-r--r--dev-ruby/request_store/request_store-1.1.0.ebuild23
-rw-r--r--dev-ruby/request_store/request_store-1.2.0.ebuild23
5 files changed, 80 insertions, 0 deletions
diff --git a/dev-ruby/request_store/Manifest b/dev-ruby/request_store/Manifest
new file mode 100644
index 000000000000..0f3359e0a7e1
--- /dev/null
+++ b/dev-ruby/request_store/Manifest
@@ -0,0 +1,3 @@
+DIST request_store-1.0.5.gem 6656 SHA256 70adb9485eb22113bd165e259b929a449dfe2d2410a880566f06df6a164fc1cf SHA512 0d69ebdb8d3f6df11f89780c250b5fcc702258e19d7fbf8e2273614ecc220ee25e059a596a8a7e39bcc426f8d834cab38c161c0c1a800cc7ebdba3daa810e727 WHIRLPOOL e3dc2ff0d349019aff440a371f6444e7703dc3481636a6e3e9d09b9cfbd153d6a887bae94d3b07a9fc67fadc4acc79e5848cdb5cdc8e3c30d224b524e47361c7
+DIST request_store-1.1.0.gem 8192 SHA256 01909a8bf54cdfe2d42ad92aaf94774bb0adc9751f6da73e86212c92b6ecad97 SHA512 5312977aad8f90a554d29cf1b0e6a82384871f0ceb45dcc41ea5e5cd6f580267815c6efba9707b5f2b27b0aebb1c83fe1a8be4990e177d48695e109058b60925 WHIRLPOOL 9333bffaa42c50a1ea32e70f042155a1895290ef6da36c29c02c9e135951d1b586cd604cb06ad97f3afa445e616e5c397744eb70ce82468d75c36a671df24217
+DIST request_store-1.2.0.gem 8192 SHA256 8540c6250b0d6a1370b430f401baabb2dec76996d5e307117458bc456799f4e8 SHA512 d96fa7563eb620a97c3a866ab0647553e118f2e788f2d8614319ef160ad036c396ab87bb7bfcba47b1774971ca7bdd63b28e002481e838511e9093c71f4d951b WHIRLPOOL d613d85df863b7eb9a4eb0a4c075c73a648cabf090a8265de14b3ebdb765f1c7df3593b746a1cf7086124526c15c7009844b2a101229511c3faab69383f8c978
diff --git a/dev-ruby/request_store/metadata.xml b/dev-ruby/request_store/metadata.xml
new file mode 100644
index 000000000000..bd8130ea8a74
--- /dev/null
+++ b/dev-ruby/request_store/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">steveklabnik/request_store</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/request_store/request_store-1.0.5.ebuild b/dev-ruby/request_store/request_store-1.0.5.ebuild
new file mode 100644
index 000000000000..bdbb65bcfa28
--- /dev/null
+++ b/dev-ruby/request_store/request_store-1.0.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Per-request global storage for Rack"
+HOMEPAGE="https://github.com/steveklabnik/request_store"
+
+LICENSE="MIT"
+SLOT="1.0.5"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_all_prepare() {
+ sed -i -e "/bundler/d" Rakefile || die
+}
diff --git a/dev-ruby/request_store/request_store-1.1.0.ebuild b/dev-ruby/request_store/request_store-1.1.0.ebuild
new file mode 100644
index 000000000000..98a61ee6cd29
--- /dev/null
+++ b/dev-ruby/request_store/request_store-1.1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Per-request global storage for Rack"
+HOMEPAGE="https://github.com/steveklabnik/request_store"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_all_prepare() {
+ sed -i -e "/bundler/d" Rakefile || die
+}
diff --git a/dev-ruby/request_store/request_store-1.2.0.ebuild b/dev-ruby/request_store/request_store-1.2.0.ebuild
new file mode 100644
index 000000000000..98a61ee6cd29
--- /dev/null
+++ b/dev-ruby/request_store/request_store-1.2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Per-request global storage for Rack"
+HOMEPAGE="https://github.com/steveklabnik/request_store"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_all_prepare() {
+ sed -i -e "/bundler/d" Rakefile || die
+}