summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/require_relative
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/require_relative')
-rw-r--r--dev-ruby/require_relative/Manifest1
-rw-r--r--dev-ruby/require_relative/metadata.xml5
-rw-r--r--dev-ruby/require_relative/require_relative-1.0.3-r1.ebuild28
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/require_relative/Manifest b/dev-ruby/require_relative/Manifest
new file mode 100644
index 000000000000..1fdfe6a2afe0
--- /dev/null
+++ b/dev-ruby/require_relative/Manifest
@@ -0,0 +1 @@
+DIST require_relative-1.0.3.gem 7168 SHA256 b295be340269ae8c39dae4270bb158caedad4ca0a9359581b041b7bc147a063c SHA512 95cd5d2c0441d8a10fa099db10a303a30b5b3de25025b61ef2ce49ad473f0ec6d67a2a66ad6f8a8841a5f9582b418d56bccf2feb311fc64cb20da1c707be6e3d WHIRLPOOL fa752baa6fb58427ede782423aa1e9255a2bf43058ed9741ff53f28d9c4c9b0685f478a9238b8b6c1fd2d6396d1ca280ab5179c71c4706df7273526415fa9756
diff --git a/dev-ruby/require_relative/metadata.xml b/dev-ruby/require_relative/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/require_relative/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/require_relative/require_relative-1.0.3-r1.ebuild b/dev-ruby/require_relative/require_relative-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..a2fb8de7359a
--- /dev/null
+++ b/dev-ruby/require_relative/require_relative-1.0.3-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+# Documentation can be generated using rocco but that is not available
+# yet.
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Backport require_relative from ruby 1.9.2"
+HOMEPAGE="http://steveklabnik.github.com/require_relative"
+
+LICENSE="|| ( Ruby BSD WTFPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+ruby_add_bdepend "test? ( virtual/ruby-minitest )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile test/require_relative_test.rb || die
+}