summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/rmagick
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/rmagick')
-rw-r--r--dev-ruby/rmagick/Manifest2
-rw-r--r--dev-ruby/rmagick/metadata.xml9
-rw-r--r--dev-ruby/rmagick/rmagick-2.13.2-r1.ebuild57
-rw-r--r--dev-ruby/rmagick/rmagick-2.13.4.ebuild56
4 files changed, 124 insertions, 0 deletions
diff --git a/dev-ruby/rmagick/Manifest b/dev-ruby/rmagick/Manifest
new file mode 100644
index 000000000000..923c6d16bcfd
--- /dev/null
+++ b/dev-ruby/rmagick/Manifest
@@ -0,0 +1,2 @@
+DIST RMagick-2.13.2.tar.bz2 1208478 SHA256 a8c2df101549f74c66f687eceada6b703183234d7ce67dc84d85d16745a638e3 SHA512 b7e9111b9221467f827e57e1d3113d714dcc5cfd32483a2a3aefc5a59fe7f98efae612145db097c3837ef55c2acd0cdde6638a94ffb595a0fba412edeb469530 WHIRLPOOL 4d89bd1a1fa341b83b539437b8a4893f955d2b196e4469d106acb49b6eac28f6777a82e4120f6a88ffc06e0d2d84e40531f713cd39388584d70ff992422b2a75
+DIST rmagick-2.13.4.gem 1539584 SHA256 7877ce2fe1b05e51e62b0a4f5d17ecae6223c17bdb61c9b4e1715dd74d541afa SHA512 c458867654af82adf10e74408055920e01963292c7890b581f473f30a8b090998f085f1701e42190ee1f62de44fcecb5e593df74e68c9d7a8fc8050f359ff643 WHIRLPOOL 2aa5fc6dbc7787d41b46ec36c6e85540aa85e020c9e060df6d2ea22c74e80665f68c32e07d70a10a3a95911943c25724c92730f1edd05c7ccda3867bb725d239
diff --git a/dev-ruby/rmagick/metadata.xml b/dev-ruby/rmagick/metadata.xml
new file mode 100644
index 000000000000..7001688936fa
--- /dev/null
+++ b/dev-ruby/rmagick/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="rubyforge">rmagick</remote-id>
+ <remote-id type="github">gemhome/rmagick</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rmagick/rmagick-2.13.2-r1.ebuild b/dev-ruby/rmagick/rmagick-2.13.2-r1.ebuild
new file mode 100644
index 000000000000..c735aa321e3f
--- /dev/null
+++ b/dev-ruby/rmagick/rmagick-2.13.2-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.html README-Mac-OSX.txt"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="An interface between Ruby and the ImageMagick(TM) image processing library"
+HOMEPAGE="http://rmagick.rubyforge.org/"
+SRC_URI="mirror://rubyforge/rmagick/RMagick-${PV}.tar.bz2"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="amd64 hppa ~mips ppc ppc64 x86 ~x86-macos"
+IUSE="doc"
+
+# hdri causes extensive changes in the imagemagick internals, and
+# rmagick is not ready to deal with those, see bug 184356.
+RDEPEND+=" >=media-gfx/imagemagick-6.4.9:=[-hdri]"
+DEPEND+=" >=media-gfx/imagemagick-6.4.9:=[-hdri]"
+
+RUBY_S="RMagick-${PV}"
+
+each_ruby_configure() {
+ pushd ext/RMagick
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+ popd
+}
+
+each_ruby_compile() {
+ pushd ext/RMagick
+ emake V=1
+ popd
+}
+
+each_ruby_install() {
+ each_fakegem_install
+ ruby_fakegem_newins ext/RMagick/RMagick2$(get_modname) lib/RMagick2$(get_modname)
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*
+
+ if use doc ; then
+ dohtml -r doc
+ fi
+}
diff --git a/dev-ruby/rmagick/rmagick-2.13.4.ebuild b/dev-ruby/rmagick/rmagick-2.13.4.ebuild
new file mode 100644
index 000000000000..3213c3578381
--- /dev/null
+++ b/dev-ruby/rmagick/rmagick-2.13.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.textile"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="An interface between Ruby and the ImageMagick(TM) image processing library"
+HOMEPAGE="https://github.com/gemhome/rmagick"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~x86 ~x86-macos"
+IUSE="doc"
+
+# Since 2.13.3 rmagick now supports HDRI enabled, but with it enabled
+# tests fail with segmentation faults.
+RDEPEND+=" >=media-gfx/imagemagick-6.4.9:=[-hdri]"
+DEPEND+=" >=media-gfx/imagemagick-6.4.9:=[-hdri]"
+
+all_ruby_prepare() {
+ # Avoid unused dependency on rake-compiler. This also avoids an
+ # extra compile during tests.
+ sed -i -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/end/ s:^:#:' \
+ -e '/compile/ s:^:#:' Rakefile || die
+
+ # Squelch harmless warning about imagemagick installation.
+ sed -i -e '/prefix/ s:ImageMagick:ImageMagick-6:' ext/RMagick/extconf.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/RMagick extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake -Cext/RMagick V=1
+ cp ext/RMagick/RMagick2$(get_modname) lib/ || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*
+
+ if use doc ; then
+ dohtml -r doc
+ fi
+}