summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-19 12:44:23 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-19 13:27:58 +0200
commitdf334212bda6eedbdeb6b6e363996c8a16d34e81 (patch)
tree8a89d6a9993b0850cfa9a08a867477edfe03b193 /dev-ruby/rrdtool-bindings/rrdtool-bindings-1.6.0.ebuild
parentmedia-sound/mixxx: Remove python2 (diff)
downloadgentoo-df334212bda6eedbdeb6b6e363996c8a16d34e81.tar.gz
gentoo-df334212bda6eedbdeb6b6e363996c8a16d34e81.tar.bz2
gentoo-df334212bda6eedbdeb6b6e363996c8a16d34e81.zip
dev-ruby/rrdtool-bindings: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-ruby/rrdtool-bindings/rrdtool-bindings-1.6.0.ebuild')
-rw-r--r--dev-ruby/rrdtool-bindings/rrdtool-bindings-1.6.0.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.6.0.ebuild b/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.6.0.ebuild
deleted file mode 100644
index b0e52ca54cd0..000000000000
--- a/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.6.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit ruby-ng
-
-MY_P=${P/-bindings}
-MY_P=${MY_P/_/-}
-
-DESCRIPTION="Ruby bindings for rrdtool"
-HOMEPAGE="https://oss.oetiker.ch/rrdtool/"
-SRC_URI="https://oss.oetiker.ch/rrdtool/pub/${MY_P}.tar.gz"
-RUBY_S="$MY_P"/bindings/ruby
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
-IUSE="graph test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="test? ( graph )"
-
-# Block on older versions of rrdtool that install the bindings themselves.
-# requires rrd_xport which requires rrd_graph
-RDEPEND="
- ~net-analyzer/rrdtool-${PV}[graph=]
-"
-DEPEND="
- ${RDEPEND}
- test? ( ~net-analyzer/rrdtool-${PV}[graph] )
-"
-
-RUBY_PATCHES=(
- "${FILESDIR}"/${PN}-1.4.8-graph-ruby.patch
-)
-
-each_ruby_configure() {
- rm ../../src/rrd_config.h || die
- touch ../../src/rrd_config.h || die
-
- ${RUBY} extconf.rb \
- --with-cflags="${CFLAGS} $(usex graph -DHAVE_RRD_GRAPH -UHAVE_RRD_GRAPH)" || die
-}
-
-each_ruby_compile() {
- emake V=1 ABS_TOP_SRCDIR="${PWD}/../.."
-}
-
-each_ruby_test() {
- if use graph; then
- ${RUBY} -I. test.rb || die
- fi
-}
-
-all_ruby_install() {
- dodoc CHANGES README
-}
-
-each_ruby_install() {
- DESTDIR=${D} emake install
-}