summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-12-09 07:39:18 +0100
committerHans de Graaff <graaff@gentoo.org>2016-12-09 07:41:10 +0100
commit7bedfb2e98e5f1cf62e9baff82e9ea899d86ea9a (patch)
tree5da289eb423f186719ba11b5f006f3b364c863ac /dev-ruby/rspec-core/rspec-core-2.14.8-r4.ebuild
parentdev-ruby/rspec-expectations: add ruby22 (diff)
downloadgentoo-7bedfb2e98e5f1cf62e9baff82e9ea899d86ea9a.tar.gz
gentoo-7bedfb2e98e5f1cf62e9baff82e9ea899d86ea9a.tar.bz2
gentoo-7bedfb2e98e5f1cf62e9baff82e9ea899d86ea9a.zip
dev-ruby/rspec-core: add ruby22
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/rspec-core/rspec-core-2.14.8-r4.ebuild')
-rw-r--r--dev-ruby/rspec-core/rspec-core-2.14.8-r4.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-ruby/rspec-core/rspec-core-2.14.8-r4.ebuild b/dev-ruby/rspec-core/rspec-core-2.14.8-r4.ebuild
index f11c42bb1636..375dd7b8d76d 100644
--- a/dev-ruby/rspec-core/rspec-core-2.14.8-r4.ebuild
+++ b/dev-ruby/rspec-core/rspec-core-2.14.8-r4.ebuild
@@ -3,7 +3,7 @@
# $Id$
EAPI=5
-USE_RUBY="ruby20 ruby21"
+USE_RUBY="ruby20 ruby21 ruby22"
RUBY_FAKEGEM_TASK_TEST="none"
RUBY_FAKEGEM_TASK_DOC="none"
@@ -20,7 +20,7 @@ RUBY_FAKEGEM_GEMSPEC="rspec-core.gemspec"
inherit ruby-fakegem
DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
-HOMEPAGE="http://rspec.rubyforge.org/"
+HOMEPAGE="https://github.com/rspec/rspec-core"
SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
LICENSE="MIT"
@@ -49,7 +49,9 @@ all_ruby_prepare() {
# Cover all released versions of ruby 2.1.x. This should be reported
# upstream since ruby 2.1.x uses semantic versioning and the file
# should not have the full version number.
- cp spec/rspec/core/formatters/text_mate_formatted-2.1.0.html spec/rspec/core/formatters/text_mate_formatted-2.1.1.html|| die
+ cp spec/rspec/core/formatters/text_mate_formatted-2.1.0.html spec/rspec/core/formatters/text_mate_formatted-2.1.9.html|| die
+ cp spec/rspec/core/formatters/text_mate_formatted-2.1.0.html spec/rspec/core/formatters/text_mate_formatted-2.1.10.html|| die
+ cp spec/rspec/core/formatters/text_mate_formatted-2.1.0.html spec/rspec/core/formatters/text_mate_formatted-2.2.6.html|| die
# Duplicate exe also in bin. We can't change it since internal stuff
# also depends on this and fixing that is going to be fragile. This
@@ -62,6 +64,9 @@ all_ruby_prepare() {
# Avoid aruba dependency so that we don't end up in dependency hell.
sed -i -e '/aruba/ s:^:#:' -e '104,106 s:^:#:' spec/spec_helper.rb || die
rm spec/command_line/order_spec.rb || die
+
+ # Avoid testing issues with rspec 3 installed
+ sed -i -e '2igem "rspec", "~> 2.0"' bin/rspec || die
}
each_ruby_prepare() {