summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-10-03 07:45:34 +0200
committerHans de Graaff <graaff@gentoo.org>2016-10-03 07:45:34 +0200
commit495e7e75f452c2817231d3fbf1f04f50c7439e4f (patch)
tree61798d9619bf9b9d8c7e3994fbf3df2a819ab208 /dev-ruby/rspec-core
parentdev-ruby/rspec-core: cleanup (diff)
downloadgentoo-495e7e75f452c2817231d3fbf1f04f50c7439e4f.tar.gz
gentoo-495e7e75f452c2817231d3fbf1f04f50c7439e4f.tar.bz2
gentoo-495e7e75f452c2817231d3fbf1f04f50c7439e4f.zip
dev-ruby/rspec-core: add 3.5.4
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/rspec-core')
-rw-r--r--dev-ruby/rspec-core/Manifest1
-rw-r--r--dev-ruby/rspec-core/rspec-core-3.5.4.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/dev-ruby/rspec-core/Manifest b/dev-ruby/rspec-core/Manifest
index 3de824bbd3a8..6f1a480cbcd9 100644
--- a/dev-ruby/rspec-core/Manifest
+++ b/dev-ruby/rspec-core/Manifest
@@ -3,3 +3,4 @@ DIST rspec-core-2.99.2-git.tgz 212935 SHA256 75794e3f94f3323b1212b93e827d37d6ab2
DIST rspec-core-3.3.2-git.tgz 332730 SHA256 aef9a2867a435aa7be57826c850e88e593232077dc42f12bfed89a92c7704d26 SHA512 6cadfa43d63df8d24105d88d6e8b22a495a30f04b289c71c8887ea3fead9ec8f071a6c734a140b1e4910f25094fd36c7c37b54a0724e734233ca584202f0cf32 WHIRLPOOL 1e385223ea8c9b32bfc6ecc93146ccad793441bae3426f6cb4acc07d7a1f2bc6e20be11597fcd27f3c6bb207482213e2eaf214835041df631d06b9bc524e5b70
DIST rspec-core-3.4.4-git.tgz 355992 SHA256 a1f3cbf0748ac87a5b3b5bea2428121e1c6ab6a2133f466da81dfbb49bb22785 SHA512 f73eda7bab8622f7457286e4c2a19d8ee231f484743d9963cd4a020d149eaad19007e8d5d4eb049e4fe62ead4f7a84de55e63ac1ac26e2c7b6d599d14eaa17b7 WHIRLPOOL 1c25e860ce672da49e3d5d95b92ceef9d92fcb44095401926e166463ea8b21ac6cdcdc615cdec6b33bdb48e5ca7689febdfa41f18ae9254536e6b958d37eb780
DIST rspec-core-3.5.3-git.tgz 368960 SHA256 26a5788977ba1ce6889924e6e944d1a08becb059593f297b4f4dd58b600b037a SHA512 c8f983018e33bd111c75671d7208b38704dd0fddb22cca2b08a59a1e5ceb0939ed56ee4015df758f5d766fbe2390279c1d670f6fff4eef222f44621f48c581ef WHIRLPOOL 86afe335378b5e9e94ee53546d6e87c531bee71cc1ed5a79f1549d593f6912a6a07dfac2b783aaaaf808bba8405e6e1cbc5b20fc275ca80ce504bed1b4991fd2
+DIST rspec-core-3.5.4-git.tgz 369170 SHA256 6e7f0cbccf13f774936b25100f743682bb4359040f926a7aa83dce9d7e80209e SHA512 c672381e9233b6f8c6e92ed70d084ff7a558edd6ca7d5a09a28fff1554975b952b6fab94483324b5bd6a62ff7aac576e7a216dbb3972749ef0210fe1cd05411d WHIRLPOOL 816b9dc1648afd11965457b147a5748ea50fd9cef8b5e266a83131b532642f5882bde9099e037ee9f5bea2fa2bc2bca1140494d33f252ea7819b033a4b8dda99
diff --git a/dev-ruby/rspec-core/rspec-core-3.5.4.ebuild b/dev-ruby/rspec-core/rspec-core-3.5.4.ebuild
new file mode 100644
index 000000000000..07e4cff850be
--- /dev/null
+++ b/dev-ruby/rspec-core/rspec-core-3.5.4.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC="none"
+
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+# Also install this custom path since internal paths depend on it.
+RUBY_FAKEGEM_EXTRAINSTALL="exe"
+
+RUBY_FAKEGEM_GEMSPEC="rspec-core.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec-core"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc64 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="highlight"
+
+SUBVERSION="$(get_version_component_range 1-2)"
+
+ruby_add_rdepend "
+ =dev-ruby/rspec-support-${SUBVERSION}*
+ !!<dev-ruby/rspec-core-2.14.8-r4
+ highlight? ( >=dev-ruby/coderay-1.0.9 )
+"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/nokogiri-1.5.2
+ >=dev-ruby/coderay-1.0.9
+ dev-ruby/syntax
+ >=dev-ruby/thread_order-1.1.0
+ >=dev-ruby/rspec-expectations-3.3.0:3
+ >=dev-ruby/rspec-mocks-2.99.0:3
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Avoid dependency on cucumber since we can't run the features anyway.
+ sed -i -e '/[Cc]ucumber/ s:^:#:' Rakefile || die
+
+ # Duplicate exe also in bin. We can't change it since internal stuff
+ # also depends on this and fixing that is going to be fragile. This
+ # way we can at least install proper bin scripts.
+ cp -R exe bin || die
+
+ # Avoid unneeded dependency on git.
+ sed -i -e 's/git ls-files --/find/' rspec-core.gemspec || die
+
+ # Avoid aruba dependency so that we don't end up in dependency hell.
+ sed -i -e '/ArubaLoader/,/^end/ s:^:#:' -e '/Aruba/ s:^:#:' spec/spec_helper.rb || die
+ rm spec/integration/{failed_line_detection,filtering,order,persistence_failures,suite_hooks_errors}_spec.rb spec/support/aruba_support.rb || die
+
+ # Avoid a spec failing due to path issues
+ sed -i -e '/does not load files in the default path when run by ruby/,/end/ s:^:#:' \
+ spec/rspec/core/configuration_spec.rb || die
+
+ # Avoid specs for older coderay version which is no longer packaged
+ sed -i -e '/highlights the syntax of the provided lines/ s/do/,skip: true do/' \
+ -e '/dynamically adjusts to changing color config/ s/do/,skip: true do/' \
+ spec/rspec/core/source/syntax_highlighter_spec.rb
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby -e:'${RUBY}' -e:' spec/rspec/core_spec.rb || die
+
+ # case ${RUBY} in
+ # *ruby22)
+ # # The rubygems version bundled with ruby 2.2 causes warnings.
+ # sed -i -e '/a library that issues no warnings when loaded/,/^ end/ s:^:#:' spec/rspec/core_spec.rb || die
+ # ;;
+ # esac
+}
+
+all_ruby_compile() {
+ if use doc ; then
+ yardoc || die
+ fi
+}
+
+each_ruby_test() {
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -Ilib bin/rspec spec || die "Tests failed."
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper rspec /usr/bin/rspec-3 'gem "rspec", "~>3.0"'
+}