summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-07-20 07:20:19 +0200
committerHans de Graaff <graaff@gentoo.org>2018-07-20 07:20:39 +0200
commitffa3cc8f51bc4cc89df692fd47de2ba4f26b8844 (patch)
treea04a378f94173444b7fc6fea54e0911ec71b6b81 /dev-ruby/rspec-core
parentdev-ruby/rspec-core: cleanup (diff)
downloadgentoo-ffa3cc8f51bc4cc89df692fd47de2ba4f26b8844.tar.gz
gentoo-ffa3cc8f51bc4cc89df692fd47de2ba4f26b8844.tar.bz2
gentoo-ffa3cc8f51bc4cc89df692fd47de2ba4f26b8844.zip
dev-ruby/rspec-core: fix dep issue with USE=doc
With USE=doc documentation is built with yardoc but dev-ruby/yard is not listed as a dependency. Adding yard as a dependency will lead to a very large and difficult to resolve circular dependency, so switch to the new default rdoc recipe instead. Closes: https://bugs.gentoo.org/636930 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-ruby/rspec-core')
-rw-r--r--dev-ruby/rspec-core/rspec-core-3.5.4.ebuild12
-rw-r--r--dev-ruby/rspec-core/rspec-core-3.6.0.ebuild10
-rw-r--r--dev-ruby/rspec-core/rspec-core-3.7.1.ebuild10
3 files changed, 7 insertions, 25 deletions
diff --git a/dev-ruby/rspec-core/rspec-core-3.5.4.ebuild b/dev-ruby/rspec-core/rspec-core-3.5.4.ebuild
index 0c937d52f425..8c95a2ed7487 100644
--- a/dev-ruby/rspec-core/rspec-core-3.5.4.ebuild
+++ b/dev-ruby/rspec-core/rspec-core-3.5.4.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+USE_RUBY="ruby23"
RUBY_FAKEGEM_TASK_TEST="none"
-RUBY_FAKEGEM_TASK_DOC="none"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
@@ -82,12 +82,6 @@ each_ruby_prepare() {
# esac
}
-all_ruby_compile() {
- if use doc ; then
- yardoc || die
- fi
-}
-
each_ruby_test() {
PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -Ilib bin/rspec spec || die "Tests failed."
}
diff --git a/dev-ruby/rspec-core/rspec-core-3.6.0.ebuild b/dev-ruby/rspec-core/rspec-core-3.6.0.ebuild
index cc729f3fa43b..6c4ff090e3f7 100644
--- a/dev-ruby/rspec-core/rspec-core-3.6.0.ebuild
+++ b/dev-ruby/rspec-core/rspec-core-3.6.0.ebuild
@@ -2,10 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+USE_RUBY="ruby22 ruby23 ruby24"
RUBY_FAKEGEM_TASK_TEST="none"
-RUBY_FAKEGEM_TASK_DOC="none"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
@@ -84,12 +84,6 @@ each_ruby_prepare() {
# esac
}
-all_ruby_compile() {
- if use doc ; then
- yardoc || die
- fi
-}
-
each_ruby_test() {
PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -Ilib bin/rspec spec || die "Tests failed."
}
diff --git a/dev-ruby/rspec-core/rspec-core-3.7.1.ebuild b/dev-ruby/rspec-core/rspec-core-3.7.1.ebuild
index 464be3781aaa..2d053a7ba98a 100644
--- a/dev-ruby/rspec-core/rspec-core-3.7.1.ebuild
+++ b/dev-ruby/rspec-core/rspec-core-3.7.1.ebuild
@@ -2,10 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+USE_RUBY="ruby23 ruby24 ruby25"
RUBY_FAKEGEM_TASK_TEST="none"
-RUBY_FAKEGEM_TASK_DOC="none"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
@@ -84,12 +84,6 @@ each_ruby_prepare() {
# esac
}
-all_ruby_compile() {
- if use doc ; then
- yardoc || die
- fi
-}
-
each_ruby_test() {
PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -Ilib bin/rspec spec || die "Tests failed."
}