summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-01-14 09:50:51 +0100
committerHans de Graaff <graaff@gentoo.org>2017-01-14 09:52:46 +0100
commit335b4e27754f922ef057ebbc45903d219148f80e (patch)
treeb21be08295f4c3e2aea6b183adfe15f018c7df52 /dev-ruby/rspec-expectations
parentdev-ruby/rspec-mocks: add ruby24 (diff)
downloadgentoo-335b4e27754f922ef057ebbc45903d219148f80e.tar.gz
gentoo-335b4e27754f922ef057ebbc45903d219148f80e.tar.bz2
gentoo-335b4e27754f922ef057ebbc45903d219148f80e.zip
dev-ruby/rspec-expectations: add ruby24
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/rspec-expectations')
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild
index 809122519c09..660cade24518 100644
--- a/dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild
+++ b/dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
RUBY_FAKEGEM_RECIPE_TEST="rspec"
@@ -50,3 +50,11 @@ all_ruby_prepare() {
# Avoid a weird, and failing, test testing already installed code.
sed -e '/has an up-to-date caller_filter file/,/end/ s:^:#:' -i spec/rspec/expectations_spec.rb || die
}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby24)
+ sed -i -e 's/of Fixnum/of Integer/' spec/rspec/expectations/expectation_target_spec.rb spec/rspec/matchers/be_instance_of_spec.rb || die
+ ;;
+ esac
+}