summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-08-05 08:37:34 +0200
committerHans de Graaff <graaff@gentoo.org>2018-08-05 08:41:00 +0200
commit35345a783ca771cb9ed6816a52179edbdd12bfdd (patch)
tree48016d3e0d33cb4400144cee10b5d43408f3cd3c /dev-ruby/rspec-expectations
parentdev-ruby/rspec-mocks: add 3.8.0 (diff)
downloadgentoo-35345a783ca771cb9ed6816a52179edbdd12bfdd.tar.gz
gentoo-35345a783ca771cb9ed6816a52179edbdd12bfdd.tar.bz2
gentoo-35345a783ca771cb9ed6816a52179edbdd12bfdd.zip
dev-ruby/rspec-expectations: add 3.8.0
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-ruby/rspec-expectations')
-rw-r--r--dev-ruby/rspec-expectations/Manifest1
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-3.8.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-ruby/rspec-expectations/Manifest b/dev-ruby/rspec-expectations/Manifest
index 27b37e10cea9..5ba53219e84f 100644
--- a/dev-ruby/rspec-expectations/Manifest
+++ b/dev-ruby/rspec-expectations/Manifest
@@ -2,3 +2,4 @@ DIST rspec-expectations-2.99.2-git.tgz 106884 BLAKE2B 5b31c8681306d5c688f62fc3fc
DIST rspec-expectations-3.5.0-git.tgz 187600 BLAKE2B 607dabc38e077ed82e18cdc690900f7fef86e6bb30a8004534992804717f8430a132b8f7d882226557e8c83832a1a8f43a32e9791b19869919c9b0aa8cfead8f SHA512 e6077549a028de0e34cdd50d93552ca3ee0f30bb550e9df20d391f287beb57070dcb3a5104627e7adb55689e7b102c91b7d3a3b944b8c4ff1235761140f2dce0
DIST rspec-expectations-3.6.0-git.tgz 193897 BLAKE2B f3fc2b06a317e77838e2d483416ab0e05aefed8a129058ceaf1a80d3068b41e81abc9fd85576433fd1577e6114ccc65130734b850997f89310b80b549f80d679 SHA512 5c784eff2c076623f471bcfff6e014420782c8d52ff54a68adc9b4d6b60a91726da36e3989535f4ab7f1fcc6b1e2a3c3a63ee330f8ea55f475711741762c0f07
DIST rspec-expectations-3.7.0-git.tgz 194071 BLAKE2B 67c8db15c43cc1141b19c6eb99390eaaf2535ec03f0fdc7b05576daa463d252f56ff251d40f5771726ee6451d57eef206c893f2593b01d413b5d96cdf21f0daf SHA512 bdd3222089299e9bfdd6f17a2b8af81d5e695290a3ce976630d586d51ff2df5baf76a3887b8adb31294bd6623ba85f8c2a4a31ac520046515aeeb81fa3a1bd5a
+DIST rspec-expectations-3.8.0-git.tgz 198184 BLAKE2B 4bd191885a7944ca4909a1275618726cd0fff95352ef7e88f05d94e5f7088632d2c9ac7a9f47ea94c79e3665198482098daf7f6fc286c59563c8efbdee585241 SHA512 7157dcf09c18d2b56156ba4c1b0bc1a11cb98ab05e43ab9cbd65eea3f796cadf3319711d4e9837905cbba8d70cf297aea47f1f8631fd7a97be763dd33ce08002
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-3.8.0.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-3.8.0.ebuild
new file mode 100644
index 000000000000..f478350c65ef
--- /dev/null
+++ b/dev-ruby/rspec-expectations/rspec-expectations-3.8.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem eapi7-ver
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec-expectations"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+SUBVERSION="$(ver_cut 1-2)"
+
+ruby_add_rdepend ">=dev-ruby/diff-lcs-1.2.0 <dev-ruby/diff-lcs-2
+ =dev-ruby/rspec-support-${SUBVERSION}*"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rspec-mocks-3.2.0:3
+ >=dev-ruby/rspec-support-3.5.0:3
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm -f Gemfile || die
+
+ # fix up the gemspecs
+ sed -i \
+ -e '/git ls/d' \
+ -e '/add_development_dependency/d' \
+ "${RUBY_FAKEGEM_GEMSPEC}" || die
+}