summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-09-07 08:18:11 +0200
committerHans de Graaff <graaff@gentoo.org>2019-09-07 14:28:35 +0200
commitfbce720583166acb4816b36d94433e50059e0890 (patch)
tree9529346a4138eeac1236d8066720d62c4f80ffd0 /dev-ruby/ruby-glib2/ruby-glib2-3.3.7.ebuild
parentapp-emacs/mediawiki: Compatibility fix in url-compat-retrieve. (diff)
downloadgentoo-fbce720583166acb4816b36d94433e50059e0890.tar.gz
gentoo-fbce720583166acb4816b36d94433e50059e0890.tar.bz2
gentoo-fbce720583166acb4816b36d94433e50059e0890.zip
dev-ruby/ruby-glib2: add 3.3.7
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/ruby-glib2/ruby-glib2-3.3.7.ebuild')
-rw-r--r--dev-ruby/ruby-glib2/ruby-glib2-3.3.7.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/ruby-glib2/ruby-glib2-3.3.7.ebuild b/dev-ruby/ruby-glib2/ruby-glib2-3.3.7.ebuild
new file mode 100644
index 000000000000..177fc7b8c9df
--- /dev/null
+++ b/dev-ruby/ruby-glib2/ruby-glib2-3.3.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+inherit ruby-ng-gnome2
+
+DESCRIPTION="Ruby Glib2 bindings"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+RDEPEND+=" >=dev-libs/glib-2"
+DEPEND+=" >=dev-libs/glib-2"
+
+ruby_add_bdepend ">=dev-ruby/pkg-config-1.3.5
+ test? ( >=dev-ruby/test-unit-2 )"
+
+all_ruby_prepare() {
+ # Skip spawn tests since our sandbox also provides items in the environment and this makes the test fragile.
+ rm -f test/test-spawn.rb || die
+
+ # Remove pregenerated Makefile since it will otherwise be shared by all targets.
+ rm -f Makefile Makefile.lib ext/glib2/Makefile || die
+
+ # Avoid native installer
+ sed -i -e '/native-package-installer/ s:^:#:' -e '/^setup_homebrew/ s:^:#:' lib/mkmf-gnome2.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die
+}