summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2017-03-16 10:05:29 +0900
committerNaohiro Aota <naota@gentoo.org>2017-03-16 10:14:07 +0900
commitc56c22edaca843cc3ad3b13ba4312860d25433f6 (patch)
tree8f242fb1f6b86edb07802b3c256b449ce2181181 /dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.1.1.ebuild
parentdev-ruby/rcairo: drop ruby20; add ruby24 (diff)
downloadgentoo-c56c22edaca843cc3ad3b13ba4312860d25433f6.tar.gz
gentoo-c56c22edaca843cc3ad3b13ba4312860d25433f6.tar.bz2
gentoo-c56c22edaca843cc3ad3b13ba4312860d25433f6.zip
dev-ruby/ruby-gnome2: bump to 3.1.1 packages
Package-Manager: Portage-2.3.4, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.1.1.ebuild')
-rw-r--r--dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.1.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.1.1.ebuild b/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.1.1.ebuild
new file mode 100644
index 000000000000..9781c969f6f4
--- /dev/null
+++ b/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+inherit ruby-ng-gnome2
+
+RUBY_S=ruby-gnome2-all-${PV}/gobject-introspection
+
+DESCRIPTION="Ruby GObjectIntrospection bindings"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND+=" dev-libs/gobject-introspection"
+RDEPEND+=" dev-libs/gobject-introspection"
+
+ruby_add_rdepend "~dev-ruby/ruby-glib2-${PV}"
+
+all_ruby_prepare() {
+ # Remove pregenerated Makefile since it will otherwise be shared by all targets.
+ rm -f Makefile Makefile.lib ext/gobject-introspection/Makefile || die
+
+ # Avoid unneeded dependency on test-unit-notify.
+ sed -i -e '/notify/ s:^:#:' test/gobject-introspection-test-utils.rb || die
+
+ # Avoid compilation of dependencies during test.
+ sed -i -e '/system/,/^ end/ s:^:#:' test/run-test.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die
+}