summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-12-20 20:28:01 +0100
committerHans de Graaff <graaff@gentoo.org>2015-12-20 20:28:01 +0100
commit98eda43afbda2a91e1b865eb87627a385f6fa578 (patch)
treee36ef29be43aa0cc0bd7f56eb1b1aec20b37fb81 /dev-ruby/ruby-oci8/ruby-oci8-2.2.1.ebuild
parentdev-ruby/ruby-oci8: fix building with USE=doc, bug 568434 (diff)
downloadgentoo-98eda43afbda2a91e1b865eb87627a385f6fa578.tar.gz
gentoo-98eda43afbda2a91e1b865eb87627a385f6fa578.tar.bz2
gentoo-98eda43afbda2a91e1b865eb87627a385f6fa578.zip
dev-ruby/ruby-oci8: add 2.2.1
Untested bump due to lack of Oracle libraries. Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-ruby/ruby-oci8/ruby-oci8-2.2.1.ebuild')
-rw-r--r--dev-ruby/ruby-oci8/ruby-oci8-2.2.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/ruby-oci8/ruby-oci8-2.2.1.ebuild b/dev-ruby/ruby-oci8/ruby-oci8-2.2.1.ebuild
new file mode 100644
index 000000000000..bf9bfefa0db9
--- /dev/null
+++ b/dev-ruby/ruby-oci8/ruby-oci8-2.2.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+inherit multilib ruby-fakegem
+
+RUBY_FAKEGEM_EXTRADOC="NEWS README.md ChangeLog"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+DESCRIPTION="A Ruby library for Oracle OCI8"
+HOMEPAGE="https://rubygems.org/gems/ruby-oci8/"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND+=" dev-db/oracle-instantclient-basic"
+DEPEND+=" dev-db/oracle-instantclient-basic"
+
+EXT_DIR="ext/oci8"
+
+each_ruby_configure() {
+ # configure the native libraries
+ ${RUBY} -C${EXT_DIR} extconf.rb --prefix="${D}/usr" || die "configure failed"
+}
+
+each_ruby_compile() {
+ # compile the native libraries
+ emake -C ${EXT_DIR} V=1 || die "could not compile native library"
+}
+
+each_ruby_install() {
+ # install the native libraries
+ emake -C ${EXT_DIR} install DESTDIR="${D}" || die "could not install native library"
+ # install the gem files
+ each_fakegem_install
+}