summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-09-08 14:02:36 +0200
committerHans de Graaff <graaff@gentoo.org>2020-09-08 14:02:57 +0200
commit5778165db418d4f057579e5a83b0143f74815636 (patch)
treeda0f945de768dd8ae7b9f10cb6fa4fdc6f94087e /dev-ruby/ruby-prof
parentdev-ruby/ruby-progressbar: cleanup (diff)
downloadgentoo-5778165db418d4f057579e5a83b0143f74815636.tar.gz
gentoo-5778165db418d4f057579e5a83b0143f74815636.tar.bz2
gentoo-5778165db418d4f057579e5a83b0143f74815636.zip
dev-ruby/ruby-prof: add 1.4.1
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/ruby-prof')
-rw-r--r--dev-ruby/ruby-prof/Manifest1
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-1.4.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-ruby/ruby-prof/Manifest b/dev-ruby/ruby-prof/Manifest
index 266b1fe550cd..8560a5d3fcac 100644
--- a/dev-ruby/ruby-prof/Manifest
+++ b/dev-ruby/ruby-prof/Manifest
@@ -1 +1,2 @@
DIST ruby-prof-0.18.0.tgz 93925 BLAKE2B f7e0825e5291fdab017035b2a71029407d2b01161f4c4c7aa1f10a80b4080ac14f7adaa2c0340fe5c80f7352181d085d724dee66597ed29825ab7116d37c5e58 SHA512 1743bbd97789c9de66e9479384d204b0870e43a265471f0fbdf7a72bb19d77a30afc25da9d0ac66a921c28ce83d8a8d72279bdd9b23cf8505ccde952092dd9a5
+DIST ruby-prof-1.4.1.tgz 90180 BLAKE2B d996474330146a5daac50f1dcc2e39ed9d3c43ab5f4851805ab264168d3a242371cf216df53c474360de164dd42c14465b4d660c4a6aee7e8983d69ea52dc4e0 SHA512 a436f5fb81bc972c799591ee1077d8fe3d092680c8c0c40ca3607f7ba49611e6fb986464df16bacc7e429ad51276f76c800457a3a68beb659ef8ad01d183434a
diff --git a/dev-ruby/ruby-prof/ruby-prof-1.4.1.ebuild b/dev-ruby/ruby-prof/ruby-prof-1.4.1.ebuild
new file mode 100644
index 000000000000..49024f019914
--- /dev/null
+++ b/dev-ruby/ruby-prof/ruby-prof-1.4.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGES"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_GEMSPEC="ruby-prof.gemspec"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A module for profiling Ruby code"
+HOMEPAGE="https://github.com/ruby-prof/ruby-prof"
+SRC_URI="https://github.com/ruby-prof/${PN}/archive/${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ # Avoid bundler
+ sed -i -e '/bundler/I s:^:#:' -e '/:build/ s:^:#:' Rakefile || die
+
+ sed -i -e '2igem "test-unit"' test/test_helper.rb || die
+
+ # We install the shared object in lib, not ext.
+ sed -i -e 's#../ext/ruby_prof#../lib/ruby_prof#' lib/ruby-prof.rb || die
+
+ # Avoid unneeded dependency on rake-compiler
+ sed -i -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/end/ s:^:#:' Rakefile || die
+
+ # Create directory required for the test suite to pass
+ mkdir tmp || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/ruby_prof extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/ruby_prof || die "build failed"
+
+ cp ext/ruby_prof/*$(get_modname) lib/ || die "copy of extension failed"
+}