summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-05-23 07:07:09 +0200
committerHans de Graaff <graaff@gentoo.org>2016-05-24 06:50:44 +0200
commit9c79e7897d952819e6af63592f201b94b8c85a9b (patch)
treed65a9e4fa22dbd4b19561b87e66e7dd852088781 /dev-ruby/ruby-prof
parentmedia-gfx/dcraw: version bump to 9.27.0 (diff)
downloadgentoo-9c79e7897d952819e6af63592f201b94b8c85a9b.tar.gz
gentoo-9c79e7897d952819e6af63592f201b94b8c85a9b.tar.bz2
gentoo-9c79e7897d952819e6af63592f201b94b8c85a9b.zip
dev-ruby/ruby-prof: cleanup
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/ruby-prof')
-rw-r--r--dev-ruby/ruby-prof/Manifest1
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.15.8-r1.ebuild63
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-ruby/ruby-prof/Manifest b/dev-ruby/ruby-prof/Manifest
index 849713911194..51d3e76188c2 100644
--- a/dev-ruby/ruby-prof/Manifest
+++ b/dev-ruby/ruby-prof/Manifest
@@ -1,2 +1 @@
-DIST ruby-prof-0.15.8.tgz 81627 SHA256 9e210052402003e41f041605291decdc5e794ae61894ab52651ffb70aeb17504 SHA512 d53fdd936dd4d7e8071a3d85877e3a82a307c62e20488ca8604e9041e4bf830568d8d1e6bde7ad463f15b07748a29669515e1a0b199e2df2562bd10a07bb935a WHIRLPOOL ce42ea37ad8b3f96c2d2a4afca8bec6cec603654a651e30cf728d24ea34c953f9a4999ee5707601c0f728231654fad9f9c5febf32dfa579bd58b5828c6957b94
DIST ruby-prof-0.15.9.tgz 83664 SHA256 000a42145bc0db20295d6feeb096788c3c6f226c9b9ee96a4d03cbb81a279cdd SHA512 6567cf29dd08be5d16a4ffb39c7475fb7daee472dba13894bdfca4a21c153bcc2f96b7b4dfb3f346e49528d593f5c29aabf9735b3f97ba7b09a97ee4514df43b WHIRLPOOL 7c052faf6e3c0ad2c0bf5dc3441166602e55f38a3694978c16af043812a8de30c3b326f5917d8bb95591c41738ccc066ebd78bc661080f20df687547ed78c9f7
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.15.8-r1.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.15.8-r1.ebuild
deleted file mode 100644
index d319c368aaf1..000000000000
--- a/dev-ruby/ruby-prof/ruby-prof-0.15.8-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20 ruby21 ruby22"
-
-RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGES"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A module for profiling Ruby code"
-HOMEPAGE="https://github.com/ruby-prof/ruby-prof"
-SRC_URI="https://github.com/ruby-prof/${PN}/archive/v${PV}.tar.gz -> ${P}.tgz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-ruby_add_bdepend "test? ( dev-ruby/test-unit:2 dev-ruby/minitest )"
-
-all_ruby_prepare() {
- # Avoid bundler
- sed -i -e '/bundler/I s:^:#:' -e '/:build/ s:^:#:' Rakefile || die
-
- sed -i -e '2igem "test-unit"' test/test_helper.rb || die
-
- # Fix a timing-dependant spec since its thresholds for success are
- # too tight.
- sed -i -e '/test_class_methods/,/^ end/ s:^:#:' test/measure_cpu_time_test.rb || die
-
- # We install the shared object in lib, not ext.
- sed -i -e 's#../ext/ruby_prof#../lib/ruby_prof#' lib/ruby-prof.rb || die
-
- # Avoid unneeded dependency on rake-compiler
- sed -i -e '/extensiontask/ s:^:#:' \
- -e '/ExtensionTask/,/end/ s:^:#:' Rakefile || die
-
- # Create directory required for the test suite to pass
- mkdir tmp || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/ruby_prof extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- emake V=1 -Cext/ruby_prof || die "build failed"
-
- cp ext/ruby_prof/*$(get_modname) lib/ || die "copy of extension failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- for dir in examples ; do
- docinto "$dir"
- dodoc -r "$dir"/*
- done
-}