summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-12-02 14:37:46 +0100
committerHans de Graaff <graaff@gentoo.org>2022-12-03 08:13:16 +0100
commitfbc3fff45eb6f7ed039d4bff8e1674bebdb8b5c8 (patch)
treead5907c3fd04c5f799dcf7dfb7a3aff92db27313 /dev-ruby/ruby-xslt
parentdev-ruby/sass: stabilize 3.7.4-r1 (diff)
downloadgentoo-fbc3fff45eb6f7ed039d4bff8e1674bebdb8b5c8.tar.gz
gentoo-fbc3fff45eb6f7ed039d4bff8e1674bebdb8b5c8.tar.bz2
gentoo-fbc3fff45eb6f7ed039d4bff8e1674bebdb8b5c8.zip
dev-ruby/ruby-xslt: drop 0.9.10
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/ruby-xslt')
-rw-r--r--dev-ruby/ruby-xslt/ruby-xslt-0.9.10.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-ruby/ruby-xslt/ruby-xslt-0.9.10.ebuild b/dev-ruby/ruby-xslt/ruby-xslt-0.9.10.ebuild
deleted file mode 100644
index d1f5ff9fe47c..000000000000
--- a/dev-ruby/ruby-xslt/ruby-xslt-0.9.10.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_FAKEGEM_EXTRADOC="ChangeLog.rdoc AUTHORS.rdoc README.rdoc"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A Ruby class for processing XSLT"
-HOMEPAGE="https://github.com/glejeune/ruby-xslt"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 x86"
-IUSE=""
-
-DEPEND+=" >=dev-libs/libxslt-1.1.12"
-RDEPEND+=" >=dev-libs/libxslt-1.1.12"
-
-all_ruby_prepare() {
- # Remove forced -g compiler flag.
- sed -i -e 's/-g //' ext/xslt_lib/extconf.rb || die
-
- # One test fails but we have installed this code already for a long
- # time so this probably isn't a regression. No upstream bug tracker
- # to report the problem :-(
- sed -i -e '/test_transformation_error/,/^ end/ s:^:#:' test/test.rb || die
-}
-
-each_ruby_configure() {
- ${RUBY} -C ext/xslt_lib extconf.rb || die
-}
-
-each_ruby_compile() {
- emake -C ext/xslt_lib V=1
- cp ext/xslt_lib/xslt_lib$(get_modname) lib/xml/ || die
-}
-
-each_ruby_test() {
- ${RUBY} -I../lib:lib -Ctest test.rb || die
-}