summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-02-23 07:28:10 +0100
committerHans de Graaff <graaff@gentoo.org>2019-02-23 07:28:10 +0100
commit951f11b5d357ddcf0b9b00ae25fb1aa9cdbed188 (patch)
tree617fba1aa29f40154cce7a2d92b3ce956fed1f6e /dev-ruby/safe_yaml/safe_yaml-1.0.5.ebuild
parentnet-vpn/libreswan: cleanup (diff)
downloadgentoo-951f11b5d357ddcf0b9b00ae25fb1aa9cdbed188.tar.gz
gentoo-951f11b5d357ddcf0b9b00ae25fb1aa9cdbed188.tar.bz2
gentoo-951f11b5d357ddcf0b9b00ae25fb1aa9cdbed188.zip
dev-ruby/safe_yaml: add 1.0.5
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/safe_yaml/safe_yaml-1.0.5.ebuild')
-rw-r--r--dev-ruby/safe_yaml/safe_yaml-1.0.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/safe_yaml/safe_yaml-1.0.5.ebuild b/dev-ruby/safe_yaml/safe_yaml-1.0.5.ebuild
new file mode 100644
index 000000000000..1f94905ba59f
--- /dev/null
+++ b/dev-ruby/safe_yaml/safe_yaml-1.0.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Parse YAML safely, alternative implementation of YAML.load"
+HOMEPAGE="https://dtao.github.com/safe_yaml"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/hashie
+ dev-ruby/heredoc_unindent
+ dev-ruby/rspec:3 )"
+
+all_ruby_prepare() {
+ sed -i -e '/local timezone/askip "timezone"' spec/transform/to_date_spec.rb || die
+}
+
+each_ruby_test() {
+ # Run specs with monkeypatch
+ ${RUBY} -S rspec-3 spec --tag ~libraries || die
+
+ # Running specs without monkeypatch
+ ${RUBY} -S rspec-3 spec --tag libraries || die
+}