summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-09-06 08:42:56 +0200
committerHans de Graaff <graaff@gentoo.org>2020-09-06 08:48:34 +0200
commitf50c19ea71c7bb8a1582934a96a518bac16c31e1 (patch)
treead6eb2c414b4193f8c38b85478a78d650f0ac5f7 /dev-ruby/safe_yaml
parentdev-ruby/whole_history_rating: cleanup (diff)
downloadgentoo-f50c19ea71c7bb8a1582934a96a518bac16c31e1.tar.gz
gentoo-f50c19ea71c7bb8a1582934a96a518bac16c31e1.tar.bz2
gentoo-f50c19ea71c7bb8a1582934a96a518bac16c31e1.zip
dev-ruby/safe_yaml: add ruby27
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/safe_yaml')
-rw-r--r--dev-ruby/safe_yaml/safe_yaml-1.0.5-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/safe_yaml/safe_yaml-1.0.5-r1.ebuild b/dev-ruby/safe_yaml/safe_yaml-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..ea0cd393ddd8
--- /dev/null
+++ b/dev-ruby/safe_yaml/safe_yaml-1.0.5-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Parse YAML safely, alternative implementation of YAML.load"
+HOMEPAGE="https://dtao.github.com/safe_yaml"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~sparc ~x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/hashie
+ dev-ruby/heredoc_unindent
+ dev-ruby/rspec:3 )"
+
+all_ruby_prepare() {
+ sed -i -e '/local timezone/askip "timezone"' spec/transform/to_date_spec.rb || die
+}
+
+each_ruby_test() {
+ # Run specs with monkeypatch
+ ${RUBY} -S rspec-3 spec --tag ~libraries || die
+
+ # Running specs without monkeypatch
+ ${RUBY} -S rspec-3 spec --tag libraries || die
+}