summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-05-08 09:18:25 +0200
committerHans de Graaff <graaff@gentoo.org>2022-05-08 09:18:31 +0200
commit929dacbbc8ce6519034b8f0158149f1a218e9dbb (patch)
tree125ef14ddb0b02f03904cbe691796411bbcb6e29 /dev-ruby/sawyer
parentdev-ruby/oauth2: enable ruby30 and disable ruby25 (diff)
downloadgentoo-929dacbbc8ce6519034b8f0158149f1a218e9dbb.tar.gz
gentoo-929dacbbc8ce6519034b8f0158149f1a218e9dbb.tar.bz2
gentoo-929dacbbc8ce6519034b8f0158149f1a218e9dbb.zip
dev-ruby/sawyer: update EAPI 6 -> 8, add ruby30
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/sawyer')
-rw-r--r--dev-ruby/sawyer/sawyer-0.8.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/sawyer/sawyer-0.8.2-r1.ebuild b/dev-ruby/sawyer/sawyer-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..97e52a84ddef
--- /dev/null
+++ b/dev-ruby/sawyer/sawyer-0.8.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="sawyer.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Secret User Agent of HTTP"
+HOMEPAGE="https://github.com/lostisland/sawyer"
+SRC_URI="https://github.com/lostisland/sawyer/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ <dev-ruby/faraday-2.0:*
+ >=dev-ruby/addressable-2.3.5"
+
+all_ruby_prepare() {
+ # Avoid tests that require network acces
+ sed -i -e '/test_blank_response_doesnt_raise/,/^ end/ s:^:#:' test/agent_test.rb || die
+}