summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-09-04 08:46:32 +0200
committerHans de Graaff <graaff@gentoo.org>2016-09-04 08:47:06 +0200
commit81d0bd1e7d8fc556d4849740d2d8c9190342ebe3 (patch)
treec1e375ecf8a0db0464e8bf31d587efbf9e93dbbc /dev-ruby/selenium-webdriver
parentdev-ruby/launchy: add ruby23 revision (diff)
downloadgentoo-81d0bd1e7d8fc556d4849740d2d8c9190342ebe3.tar.gz
gentoo-81d0bd1e7d8fc556d4849740d2d8c9190342ebe3.tar.bz2
gentoo-81d0bd1e7d8fc556d4849740d2d8c9190342ebe3.zip
dev-ruby/selenium-webdriver: add ruby23 revision
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/selenium-webdriver')
-rw-r--r--dev-ruby/selenium-webdriver/selenium-webdriver-2.53.4-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/selenium-webdriver/selenium-webdriver-2.53.4-r1.ebuild b/dev-ruby/selenium-webdriver/selenium-webdriver-2.53.4-r1.ebuild
new file mode 100644
index 000000000000..32c1cf95a2e0
--- /dev/null
+++ b/dev-ruby/selenium-webdriver/selenium-webdriver-2.53.4-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+# NOTE: this package contains precompiled code. It appears that all
+# source code can be found at https://code.google.com/p/selenium/ but the
+# repository is not organized in a way so that we can easily rebuild the
+# suited shared object. We'll just try our luck with the precompiled
+# objects for now.
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_QA_ALLOWED_LIBS="x_ignore_nofocus.so"
+QA_PREBUILT="*/x_ignore_nofocus.so"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem provides Ruby bindings for WebDriver"
+HOMEPAGE="http://gemcutter.org/gems/selenium-webdriver"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/childprocess-0.5.0
+ dev-ruby/rubyzip:1"
+
+all_ruby_prepare() {
+ # Make websocket a development dependency since it is only needed
+ # for the safari driver which we don't support on Gentoo.
+ sed -i -e '/websocket/,/version_requirements/ s/runtime/development/' ../metadata || die
+}