summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-11-07 07:17:59 +0100
committerHans de Graaff <graaff@gentoo.org>2016-11-07 07:18:43 +0100
commit61c943b8615ce67cbaee4d6a492ae1a0746cf0ce (patch)
tree000f65f812dfa96f321086cf495cb0b5350b7856 /dev-ruby/shoulda-context/shoulda-context-1.2.2.ebuild
parentdev-ruby/public_suffix: add 2.0.4 (diff)
downloadgentoo-61c943b8615ce67cbaee4d6a492ae1a0746cf0ce.tar.gz
gentoo-61c943b8615ce67cbaee4d6a492ae1a0746cf0ce.tar.bz2
gentoo-61c943b8615ce67cbaee4d6a492ae1a0746cf0ce.zip
dev-ruby/shoulda-context: add 1.2.2
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/shoulda-context/shoulda-context-1.2.2.ebuild')
-rw-r--r--dev-ruby/shoulda-context/shoulda-context-1.2.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/shoulda-context/shoulda-context-1.2.2.ebuild b/dev-ruby/shoulda-context/shoulda-context-1.2.2.ebuild
new file mode 100644
index 000000000000..af8021b3429b
--- /dev/null
+++ b/dev-ruby/shoulda-context/shoulda-context-1.2.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING.md README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb rails tasks"
+
+# Don't install the conversion script to avoid collisions with older
+# shoulda.
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Context framework extracted from Shoulda"
+HOMEPAGE="http://thoughtbot.com/projects/shoulda"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64"
+IUSE="doc test"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2
+ <dev-ruby/mocha-1 )"
+
+all_ruby_prepare() {
+ sed -i -e "1igem 'mocha', '~>0.10'\n" test/test_helper.rb || die
+}
+
+each_ruby_test() {
+ BUNDLE_GEMFILE=x ruby-ng_testrb-2 -Itest test/shoulda/*_test.rb || die
+}