summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-04-07 08:10:10 +0200
committerHans de Graaff <graaff@gentoo.org>2021-04-07 08:14:31 +0200
commit2e2dc9443cf7887f7140927ae7c5a7de003b8c6f (patch)
tree42879bb6bc94f3de4529ac22d31d9b9eb6e01514 /dev-ruby/shoulda
parentdev-ruby/mocha: add ruby30 (diff)
downloadgentoo-2e2dc9443cf7887f7140927ae7c5a7de003b8c6f.tar.gz
gentoo-2e2dc9443cf7887f7140927ae7c5a7de003b8c6f.tar.bz2
gentoo-2e2dc9443cf7887f7140927ae7c5a7de003b8c6f.zip
dev-ruby/shoulda: add ruby27, ruby30
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/shoulda')
-rw-r--r--dev-ruby/shoulda/shoulda-2.11.3-r3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/shoulda/shoulda-2.11.3-r3.ebuild b/dev-ruby/shoulda/shoulda-2.11.3-r3.ebuild
new file mode 100644
index 000000000000..905694b9e654
--- /dev/null
+++ b/dev-ruby/shoulda/shoulda-2.11.3-r3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTION_GUIDELINES.rdoc README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC=shoulda.gemspec
+
+inherit ruby-fakegem
+
+DESCRIPTION="Making tests easy on the fingers and eyes"
+HOMEPAGE="http://thoughtbot.com/projects/shoulda"
+SRC_URI="https://github.com/thoughtbot/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+RUBY_S="thoughtbot-${PN}-*"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# tests seem to be quite broken :( They require working version of
+# various rails versions. There appear to be unit and matcher tests but
+# they can't be run on their own.
+RESTRICT=test