summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/simplecov-html
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/simplecov-html')
-rw-r--r--dev-ruby/simplecov-html/Manifest2
-rw-r--r--dev-ruby/simplecov-html/metadata.xml8
-rw-r--r--dev-ruby/simplecov-html/simplecov-html-0.8.0.ebuild24
-rw-r--r--dev-ruby/simplecov-html/simplecov-html-0.9.0.ebuild24
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-ruby/simplecov-html/Manifest b/dev-ruby/simplecov-html/Manifest
new file mode 100644
index 000000000000..dec9489ca21a
--- /dev/null
+++ b/dev-ruby/simplecov-html/Manifest
@@ -0,0 +1,2 @@
+DIST simplecov-html-0.8.0.gem 180224 SHA256 69393ce932c2898dd5074913e360078f651f094a9b7300b286a78f43b11c164a SHA512 ddf53538ffa426a3ea2078bbb5ad3ddebd65b33f068c232b43a8e81bbadfa0dd4e44622038a3bc9065b437a4e8806935da09ace6b686ab20b36047df145927d1 WHIRLPOOL cc56cfdf2ddfaa5fa3310cdf8bc5472ce96873cc8fc547fc48366eeca04d90514e7f20417d1883b81818efeec313d16ce46152edf66a34f9103d5281a7a90c06
+DIST simplecov-html-0.9.0.gem 182784 SHA256 6cbf3ecc67892373da3153d042994e0ee6f3f0a0af1ac79e6619c6ae6ebd694b SHA512 64c33ea48aed50b769312609617ffdfab17cf1702e6285dd2956b56f7cffb26b8252973eb34b7c479bead27e143095334474fe6cb6f6db20f58573d3ca016e8a WHIRLPOOL 7926690d34095f2abb71866838c18210ec94bb254254db331877388da9984e39a4ae7e24e5bc6197669936b8564fa421e9e1f6d3d09d2ced0229fae269afa6d1
diff --git a/dev-ruby/simplecov-html/metadata.xml b/dev-ruby/simplecov-html/metadata.xml
new file mode 100644
index 000000000000..05cdc6836d96
--- /dev/null
+++ b/dev-ruby/simplecov-html/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">colszowka/simplecov</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/simplecov-html/simplecov-html-0.8.0.ebuild b/dev-ruby/simplecov-html/simplecov-html-0.8.0.ebuild
new file mode 100644
index 000000000000..fa339794a886
--- /dev/null
+++ b/dev-ruby/simplecov-html/simplecov-html-0.8.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRAINSTALL="assets public views"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Generates a nice HTML report of your SimpleCov ruby code coverage results on Ruby 1.9"
+HOMEPAGE="https://github.com/colszowka/simplecov"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0.8"
+IUSE="doc"
diff --git a/dev-ruby/simplecov-html/simplecov-html-0.9.0.ebuild b/dev-ruby/simplecov-html/simplecov-html-0.9.0.ebuild
new file mode 100644
index 000000000000..8c0c08dc2a40
--- /dev/null
+++ b/dev-ruby/simplecov-html/simplecov-html-0.9.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRAINSTALL="assets public views"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Generates a nice HTML report of your SimpleCov ruby code coverage results on Ruby 1.9"
+HOMEPAGE="https://github.com/colszowka/simplecov"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0.9"
+IUSE="doc"